]> code.ossystems Code Review - openembedded-core.git/commitdiff
distutils: regenerate pyc files after being modified by sed
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>
Thu, 11 Jun 2015 15:38:54 +0000 (15:38 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 23 Jun 2015 10:38:10 +0000 (11:38 +0100)
py files are edited by sed and therefore *.pyc files are recreated on first boot, but if you have a read-only filesystem this is not possible. This patch creates pyc files directly after the py files are modified.

[YOCTO #7722]

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Thomas Roos <roosesweb@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/classes/distutils.bbclass

index c0bb573cf84cf67fc6916de028ff1841ff3a6239..2498685d66e5a59eb5353e61f9d5087c968ca9ed 100644 (file)
@@ -42,8 +42,8 @@ distutils_do_install() {
         bbfatal "${PYTHON_PN} setup.py install execution failed."
 
         # support filenames with *spaces*
-        # only modify file if it contains path to avoid recompilation on the target
-        find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \;
+        # only modify file if it contains path  and recompile it
+        find ${D} -name "*.py" -exec grep -q ${D} {} \; -exec sed -i -e s:${D}::g {} \; -exec ${STAGING_BINDIR_NATIVE}/python-native/python -mcompileall {} \;
 
         if test -e ${D}${bindir} ; then        
             for i in ${D}${bindir}/* ; do \