]> code.ossystems Code Review - openembedded-core.git/commitdiff
lame: Use autotools_stage_all
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 12:03:16 +0000 (12:03 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 17 Nov 2009 12:03:16 +0000 (12:03 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/lame/lame_3.96.1.bb

index ab9a99c0647d1521a42c268d08ad37ae2f6528d0..d610b5105e86793f327c7ec158fc3e4357f59334 100644 (file)
@@ -7,7 +7,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
        file://no-gtk1.patch;patch=1 \
        file://Makefile-lm.patch;patch=1"
 
-inherit autotools
+inherit autotools_stage
 
 PACKAGES += "libmp3lame libmp3lame-dev"
 FILES_${PN} = "${bindir}/lame"
@@ -23,10 +23,3 @@ do_configure() {
        gnu-configize --force
        oe_runconf
 }
-
-do_stage() {
-       install -d ${STAGING_LIBDIR}
-       oe_libinstall -C libmp3lame -so -a libmp3lame ${STAGING_LIBDIR}
-       install -d ${STAGING_INCDIR}/lame
-       install -m 0644 include/lame.h ${STAGING_INCDIR}/lame/
-}