]> code.ossystems Code Review - openembedded-core.git/commitdiff
modutils-initscripts: fix wrong order of module loading happening in udev
authorPetr Štetiar <ynezz@true.cz>
Fri, 8 Apr 2011 13:36:37 +0000 (15:36 +0200)
committerSaul Wold <sgw@linux.intel.com>
Sat, 23 Apr 2011 05:03:56 +0000 (22:03 -0700)
In the current state, udev init script is loaded as 3rd and modutils.sh as
20th, so udevadm called in udev init script loads all kernel modules in some
unpredictable order, not honoring in any way specified order of modules in
/etc/modules. This causes some troubles mainly in the first boot. So to fix
this we now move loading of the kernel modules just before we exec udev init
script. Example of the current state:

Starting udev
rtc-m48t86 rtc-m48t86: rtc core: registered m48t86 as rtc0
rtc-m48t86 rtc-m48t86: battery ok
ep93xx-rtc ep93xx-rtc: rtc core: registered ep93xx-rtc as rtc1

root@ts72xx:~# cat /etc/modules
rtc-ep93xx
ohci-hcd
ts72xx_sbcinfo
rtc-m48t86

As you can guess, this is really wrong behaviour, because I've rtc1 as the
main time source for my system.

root@ts72xx:~# cat /etc/default/hwclock
HWCLOCKACCESS=yes
HWCLOCKDEVICE=/dev/rtc1

Expected behaviour with this patch applied:

Please wait: booting...
ep93xx-rtc ep93xx-rtc: rtc core: registered ep93xx-rtc as rtc0
usbcore: registered new device driver usb
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
...
rtc-m48t86 rtc-m48t86: rtc core: registered m48t86 as rtc1
rtc-m48t86 rtc-m48t86: battery ok
Starting udev

Signed-off-by: Petr Štetiar <ynezz@true.cz>
(based on http://patches.openembedded.org/patch/1917/)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/modutils/modutils-initscripts.bb

index 16659552914fbe0cedb853da54cbbd786d1248ac..5ae34b4df88a7ed4e92516c41dcec0fbb6f4d68c 100644 (file)
@@ -4,10 +4,10 @@ LICENSE = "PD"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=7bf87fc37976e93ec66ad84fac58c098"
 SRC_URI = "file://modutils.sh \
           file://PD.patch"
-PR = "r4"
+PR = "r5"
 
 INITSCRIPT_NAME = "modutils.sh"
-INITSCRIPT_PARAMS = "start 20 S ."
+INITSCRIPT_PARAMS = "start 2 S ."
 
 inherit update-rc.d