]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm-init: Make sure kdrive servers have the console keyboard enabled
authorRichard Purdie <rpurdie@linux.intel.com>
Thu, 11 Feb 2010 16:09:49 +0000 (16:09 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 11 Feb 2010 16:09:49 +0000 (16:09 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/x11-common/x11-common/etc/X11/Xserver
meta/packages/x11-common/xserver-nodm-init.bb

index 9a0986ad61fd1998c83d9aa9a936cf3d9850fb04..3d4aa74b9532f80de9bb985b60d31041d4cbdb60 100644 (file)
@@ -30,12 +30,9 @@ ARGS=" -br -pn"
 
 if [ "$XSERVER" != "/usr/bin/Xorg" ]; then
 
-       . /etc/formfactor/config
+        . /etc/formfactor/config
 
-        # use ucb 1x00 touchscreen if present
-        if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/touchscreen/ucb1x00 ]; then
-          ARGS="$ARGS -mouse /dev/touchscreen/ucb1x00"
-        fi
+        ARGS="$ARGS -keybd keyboard"
 
         # use usb mouse if present
         if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/input/mice ]; then
@@ -78,4 +75,3 @@ fi
 DISPLAY=':0'
 
 exec xinit /etc/X11/Xsession -- $XSERVER $DISPLAY $ARGS $*
-
index c9efb71b811c938da2a0209611dd1b291cefe356..c77b2f0f8bdf9348199c24d26532d7b8967c3299 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPL"
 SECTION = "x11"
 PRIORITY = "optional"
-PR = "r21"
+PR = "r22"
 RDEPENDS_${PN} = "dbus-wait sudo"
 
 SRC_URI = "file://xserver-nodm"
@@ -14,7 +14,7 @@ do_install() {
     install -d ${D}/etc
     install -d ${D}/etc/init.d
     install xserver-nodm ${D}/etc/init.d
-}    
+}
 
 inherit update-rc.d