]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnome-doc-utils: ensure a native variant exists for document generation
authorJoshua Lock <josh@linux.intel.com>
Fri, 17 Dec 2010 14:09:48 +0000 (14:09 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 21 Dec 2010 09:29:11 +0000 (09:29 +0000)
gnome-doc-utils-native must be available to do the build time generation of
documentation however most gnome projects will do a pkgconfig check for the
host version of gnome-doc-utils.

This patch adds gnome-doc-utils-native and makes gnome-doc-utils depend on it
so that recipe writers can just add gnome-doc-utils to their DEPENDS and the
system will do the right thing.

Signed-off-by: Joshua Lock <josh@linux.intel.com>
meta/recipes-gnome/gnome/gnome-doc-utils-native_0.20.2.bb [new file with mode: 0644]
meta/recipes-gnome/gnome/gnome-doc-utils.inc

diff --git a/meta/recipes-gnome/gnome/gnome-doc-utils-native_0.20.2.bb b/meta/recipes-gnome/gnome/gnome-doc-utils-native_0.20.2.bb
new file mode 100644 (file)
index 0000000..30d5a5b
--- /dev/null
@@ -0,0 +1,7 @@
+require gnome-doc-utils_${PV}.bb
+
+inherit native
+
+DEPENDS = "libxml2-native libxslt-native"
+
+PR = "r0"
index 00a64e2582f45fbf93fc4be4fc144a1f43bea096..0cd8203ae15ad9d589a682159fadc180446a9864 100644 (file)
@@ -1,7 +1,5 @@
 LICENSE = "GPL LGPL"
-DEPENDS = "libxml2 libxslt libxslt-native"
-
-PR = "r1"
+DEPENDS = "libxml2 libxslt libxslt-native gnome-doc-utils-native"
 
 inherit gnome