]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix crash with gst-inspect
authorChris Lord <chris@openedhand.com>
Tue, 12 Sep 2006 15:25:37 +0000 (15:25 +0000)
committerChris Lord <chris@openedhand.com>
Tue, 12 Sep 2006 15:25:37 +0000 (15:25 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@705 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gstreamer/gstreamer-0.10.9/gst-inspect-check-error.patch [new file with mode: 0644]
meta/packages/gstreamer/gstreamer_0.10.9.bb

diff --git a/meta/packages/gstreamer/gstreamer-0.10.9/gst-inspect-check-error.patch b/meta/packages/gstreamer/gstreamer-0.10.9/gst-inspect-check-error.patch
new file mode 100644 (file)
index 0000000..5da6cdd
--- /dev/null
@@ -0,0 +1,11 @@
+--- gstreamer-0.10.9/tools/gst-inspect.c.old   2006-09-12 11:56:53.000000000 +0100
++++ gstreamer-0.10.9/tools/gst-inspect.c       2006-09-12 11:57:27.000000000 +0100
+@@ -1123,7 +1123,7 @@
+   g_option_context_add_main_entries (ctx, options, GETTEXT_PACKAGE);
+   g_option_context_add_group (ctx, gst_init_get_option_group ());
+   if (!g_option_context_parse (ctx, &argc, &argv, &err)) {
+-    g_print ("Error initializing: %s\n", err->message);
++    g_print ("Error initializing: %s\n", err ? err->message : "(null)");
+     exit (1);
+   }
+   g_option_context_free (ctx);
index cdf8de72b4722ba57a8cafb3f3368cd232176618..43d5e34df420443342ca0417f1f720d5bffbe389 100644 (file)
@@ -5,15 +5,16 @@ PRIORITY = "optional"
 LICENSE = "LGPL"
 HOMEPAGE = "http://www.gstreamer.net/"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
-DEPENDS = "glib-2.0 gettext-native popt libxml2"
-PR = "r1"
+DEPENDS = "glib-2.0 gettext-native libxml2"
+PR = "r2"
 
 inherit autotools pkgconfig
 
-SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2"
-#         file://gstregistrybinary.c \
-#         file://gstregistrybinary.h \
-#         file://gstreamer-0.9-binary-registry.patch;patch=1"
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
+           file://gst-inspect-check-error.patch;patch=1"
+#           file://gstregistrybinary.c \
+#           file://gstregistrybinary.h \
+#           file://gstreamer-0.9-binary-registry.patch;patch=1"
 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no"
 
 #do_compile_prepend () {