]> code.ossystems Code Review - openembedded-core.git/commitdiff
pixman: don't use xorg-lib-common
authorRoss Burton <ross.burton@intel.com>
Thu, 19 Dec 2019 20:57:12 +0000 (20:57 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 28 Dec 2019 23:25:35 +0000 (23:25 +0000)
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-graphics/xorg-lib/pixman_0.38.4.bb

index 82c2e73e50209bbc97822b68785271d67aba003a..8588e5f16b009797f9e81c63c6e6c689f0caaabc 100644 (file)
@@ -1,24 +1,31 @@
 SUMMARY = "Pixman: Pixel Manipulation library"
-
 DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
 -- a set of Y-X banded rectangles, image compositing using the \
 Porter/Duff model and implicit mask generation for geometric primitives \
 including trapezoids, triangles, and rectangles."
+HOMEPAGE = "http://www.pixman.org"
+SECTION = "x11/libs"
+DEPENDS = "zlib libpng"
 
-require xorg-lib-common.inc
+SRC_URI = "https://www.cairographics.org/releases/${BP}.tar.gz \
+           file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
+           file://0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch \
+           "
+SRC_URI[md5sum] = "267a7af290f93f643a1bc74490d9fdd1"
+SRC_URI[sha256sum] = "da66d6fd6e40aee70f7bd02e4f8f76fc3f006ec879d346bae6a723025cfbdde7"
 
 # see http://cairographics.org/releases/ - only even minor versions are stable
 UPSTREAM_CHECK_REGEX = "pixman-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
 
+PE = "1"
+
 LICENSE = "MIT & MIT-style & PD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
                     file://pixman/pixman-matrix.c;endline=21;md5=4a018dff3e4e25302724c88ff95c2456 \
                     file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
                    "
-DEPENDS += "zlib libpng"
-BBCLASSEXTEND = "native nativesdk"
 
-PE = "1"
+inherit autotools pkgconfig
 
 IWMMXT = "--disable-arm-iwmmxt"
 LOONGSON_MMI = "--disable-loongson-mmi"
@@ -29,12 +36,4 @@ EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
 EXTRA_OECONF_class-native = "--disable-gtk"
 EXTRA_OECONF_class-nativesdk = "--disable-gtk"
 
-SRC_URI += "\
-            file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
-           file://0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch \
-"
-
-SRC_URI[md5sum] = "16a350a8a40116ddf67632a1d2623711"
-SRC_URI[sha256sum] = "84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550"
-
-REQUIRED_DISTRO_FEATURES = ""
+BBCLASSEXTEND = "native nativesdk"