]> code.ossystems Code Review - openembedded-core.git/commitdiff
ICU: add pkgconfig support
authorChen Qi <Qi.Chen@windriver.com>
Mon, 3 Dec 2012 10:21:08 +0000 (18:21 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Dec 2012 12:30:35 +0000 (12:30 +0000)
Add pkgconfig support to ICU.

[YOCTO #2453]

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/icu/files/icu-add-pkgconfig-support.patch [new file with mode: 0644]
meta/recipes-support/icu/icu-3.6.inc
meta/recipes-support/icu/icu_3.6.bb

diff --git a/meta/recipes-support/icu/files/icu-add-pkgconfig-support.patch b/meta/recipes-support/icu/files/icu-add-pkgconfig-support.patch
new file mode 100644 (file)
index 0000000..c7cd9d5
--- /dev/null
@@ -0,0 +1,43 @@
+Upstream-Status: Inappropriate [version]
+ICU-3.6 has no pkgconfig, so I add it here. 
+But ICU has had pkgconfig support since 4.6.
+So this patch is inappropriate to upstream.
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+
+Index: configure.in
+=============================================================
+--- a/configure.in
++++ b/configure.in
+@@ -1057,4 +1057,7 @@ echo "This may cause ICU to fail to build. Please make sure that GNU make"
+ echo "is in your PATH so that this configure script can detect its location."
+ fi
++AC_CONFIG_FILES([icu.pc])
++AC_OUTPUT
++
+ $as_unset _CXX_CXXSUFFIX
+
+Index: icu.pc.in
+=============================================================
+--- /dev/null
++++ b/icu.pc.in
+@@ -0,0 +1,15 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++unicode_version=@UNICODE_VERSION@
++
++Name: ICU
++Description: International Component for Unicode libraries
++Requires:
++Version: @VERSION@
++Libs: -L${libdir} -licui18n -licuuc -licudata
++Libs.private: -L{libdir} -lpthread -lm
++Cflags: -I${includedir} -O2 -pipe -g -feliminate-unused-debug-types
+-- 
+1.7.11.2
+
index 272f6d15ba681b45c9aed32874b3f5b25fccdd73..8caf71c645419a89e97b4751e29970cf03e418e2 100644 (file)
@@ -7,6 +7,7 @@ BASE_SRC_URI = "ftp://ftp.software.ibm.com/software/globalization/icu/3.6/icu4c-
            file://fix-parallel-build.patch \
            file://use-g++-for-linking.patch \
            file://larger-cmd-size.patch \
+          file://icu-add-pkgconfig-support.patch \
            "
 SRC_URI = "${BASE_SRC_URI} \
            file://noldlibpath.patch \
@@ -28,6 +29,12 @@ inherit autotools pkgconfig binconfig
 do_configure() {
        libtoolize --force
        gnu-configize --force
+       if [ "${PN}" != "icu-native" ]; then
+               OLD=`pwd`
+               cd ${S}
+               autoconf
+               cd ${OLD}
+       fi
        oe_runconf
        if [ "${PN}" != "icu-native" ]; then
                # In the non-native case we need to make substitutions to use
@@ -45,6 +52,10 @@ do_compile() {
 
 do_install_append() {
         chmod +x ${D}${libdir}/lib*
+       if [ "${PN}" != "icu-native" ]; then
+               install -d ${D}/${libdir}/pkgconfig
+               install -m 0644 ${S}/icu.pc ${D}/${libdir}/pkgconfig
+       fi
 }
 
 PACKAGES =+ "libicudata libicuuc libicui18n libicule libiculx libicutu libicuio"
index f941acf81f9e88910a598df47b00eb34628410ca..f50abe231cef9c1b5305a8f8ebb2fbb6d035e0ee 100644 (file)
@@ -1,6 +1,6 @@
 require icu-3.6.inc
 
-PR = "r9"
+PR = "r10"
 
 SRC_URI[md5sum] = "6243f7a19e03e05403ce84e597510d4c"
 SRC_URI[sha256sum] = "5135e8d69d6206d320515df7aeee7027711ab1aef9d8dbf29571a97a9746b041"