]> code.ossystems Code Review - openembedded-core.git/commitdiff
prelink_git.bb: Only block the postinst script when no image-prelink
authorMark Hatle <mark.hatle@windriver.com>
Wed, 29 Jun 2011 01:36:11 +0000 (20:36 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 Jun 2011 13:36:01 +0000 (14:36 +0100)
If image-prelink is being used, the system will automatically prelink
the target image.  This avoids the need to run the postinst prelink
script at first boot.  However, if the user has not enabled image
prelinking -- then we do enable the script to run on first boot.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/prelink/prelink_git.bb

index b57c1453534a60d7d92a2cdad670848cda0a490b..c653d4d67a17bd1efb513bd66aa1cca7d75041ae 100644 (file)
@@ -10,7 +10,7 @@ LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
 SRCREV = "ac461e73b17253a4da25c5aafeac7193b553156c"
 PV = "1.0+git${SRCPV}"
-PR = "r3"
+PR = "r4"
 
 #
 # The cron script attempts to re-prelink the system daily -- on
@@ -58,11 +58,13 @@ do_install_append () {
        install -m 0644 ${WORKDIR}/macros.prelink ${D}${sysconfdir}/rpm/macros.prelink
 }
 
+# If we're using image-prelink, we want to skip this on the host side
+# but still do it if the package is installed on the target...
 pkg_postinst_prelink() {
 #!/bin/sh
 
 if [ "x$D" != "x" ]; then
-  exit 1
+  ${@base_contains('USER_CLASSES', 'image-prelink', 'exit 0', 'exit 1', d)}
 fi
 
 prelink -a