]> code.ossystems Code Review - openembedded-core.git/commitdiff
gpgme: split packaging to package per library
authorMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 25 Mar 2008 11:52:05 +0000 (11:52 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Tue, 25 Mar 2008 11:52:05 +0000 (11:52 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4112 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gpgme/gpgme_1.1.4.bb

index 120a07e2aeca4b6151762e3e9736828a53826774..8ac8bb339873473933978520999fbbeb49562d0b 100644 (file)
@@ -1,7 +1,8 @@
+DESCRIPTION = "GPGME - GnuPG Made Easy"
 LICENSE = "GPL"
 SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
 DEPENDS = "libgpg-error pth"
-PR = "r2"
+PR = "r3"
 
 EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test \
                 --with-gpg=${bindir}/gpg --without-gpgsm"
@@ -20,4 +21,8 @@ do_stage() {
        install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
 }
 
+PACKAGES =+ "${PN}-pth ${PN}-pthread"
+FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
+FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
+FILES_${PN} = "${libdir}/libgpgme.so.*"
 FILES_${PN}-dev += "${bindir}/gpgme-config"