]> code.ossystems Code Review - openembedded-core.git/commitdiff
gdb: upgraded to 6.8
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 4 Apr 2008 15:18:57 +0000 (15:18 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 4 Apr 2008 15:18:57 +0000 (15:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4174 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gdb/files/no-werror.patch [new file with mode: 0644]
meta/packages/gdb/gdb-common.inc
meta/packages/gdb/gdb-cross-sdk_6.8.bb [moved from meta/packages/gdb/gdb-cross-sdk_6.6.bb with 100% similarity]
meta/packages/gdb/gdb-cross_6.8.bb [moved from meta/packages/gdb/gdb-cross_6.6.bb with 100% similarity]
meta/packages/gdb/gdb.inc
meta/packages/gdb/gdb_6.8.bb [moved from meta/packages/gdb/gdb_6.6.bb with 100% similarity]

diff --git a/meta/packages/gdb/files/no-werror.patch b/meta/packages/gdb/files/no-werror.patch
new file mode 100644 (file)
index 0000000..0a9faa2
--- /dev/null
@@ -0,0 +1,96 @@
+---
+ bfd/warning.m4   |    2 +-
+ configure.ac     |    2 +-
+ gdb/Makefile.in  |    4 ++--
+ gdb/configure.ac |    8 ++------
+ 4 files changed, 6 insertions(+), 10 deletions(-)
+
+--- gdb-6.8.orig/bfd/warning.m4
++++ gdb-6.8/bfd/warning.m4
+@@ -21,11 +21,11 @@ case "${host}" in
+   *) ;;
+ esac
+ # Enable -Werror by default when using gcc
+ if test "${GCC}" = yes -a -z "${ERROR_ON_WARNING}" ; then
+-    ERROR_ON_WARNING=yes
++    ERROR_ON_WARNING=no
+ fi
+ NO_WERROR=
+ if test "${ERROR_ON_WARNING}" = yes ; then
+     GCC_WARN_CFLAGS="$GCC_WARN_CFLAGS -Werror"
+--- gdb-6.8.orig/configure.ac
++++ gdb-6.8/configure.ac
+@@ -2739,11 +2739,11 @@ AC_SUBST(stage1_checking)
+ # Enable -Werror in bootstrap stage2 and later.
+ AC_ARG_ENABLE(werror,
+ [  --enable-werror         enable -Werror in bootstrap stage2 and later], [],
+ [if test -d ${srcdir}/gcc && test x"`cat $srcdir/gcc/DEV-PHASE`" = xexperimental; then
+-  enable_werror=yes
++  enable_werror=no
+ else
+   enable_werror=no
+ fi])
+ case ${enable_werror} in
+   yes) stage2_werror_flag="--enable-werror-always" ;;
+--- gdb-6.8.orig/gdb/Makefile.in
++++ gdb-6.8/gdb/Makefile.in
+@@ -140,13 +140,13 @@ READLINE_CFLAGS = @READLINE_CFLAGS@
+ # Where is expat?  This will be empty if expat was not available.
+ LIBEXPAT = @LIBEXPAT@
+ WARN_CFLAGS = @WARN_CFLAGS@
+-WERROR_CFLAGS = @WERROR_CFLAGS@
++WERROR_CFLAGS =
+ GDB_WARN_CFLAGS = $(WARN_CFLAGS)
+-GDB_WERROR_CFLAGS = $(WERROR_CFLAGS)
++GDB_WERROR_CFLAGS =
+ GDB_WARN_CFLAGS_NO_FORMAT = `echo " $(GDB_WARN_CFLAGS) " | sed "s/ -Wformat-nonliteral / /g"`
+ # Where is the INTL library?  Typically in ../intl.
+ INTL = @LIBINTL@
+--- gdb-6.8.orig/gdb/configure.ac
++++ gdb-6.8/gdb/configure.ac
+@@ -1292,24 +1292,21 @@ AC_SUBST(TARGET_SYSTEM_ROOT)
+ AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
+ AC_ARG_ENABLE(werror,
+   [  --enable-werror    treat compile warnings as errors],
+   [case "${enableval}" in
+-     yes | y) ERROR_ON_WARNING="yes" ;;
++     yes | y) ERROR_ON_WARNING="no" ;;
+      no | n)  ERROR_ON_WARNING="no" ;;
+      *) AC_MSG_ERROR(bad value ${enableval} for --enable-werror) ;;
+    esac])
+ # Enable -Werror by default when using gcc
+ if test "${GCC}" = yes -a -z "${ERROR_ON_WARNING}" ; then
+-    ERROR_ON_WARNING=yes
++    ERROR_ON_WARNING=no
+ fi
+ WERROR_CFLAGS=""
+-if test "${ERROR_ON_WARNING}" = yes ; then
+-    WERROR_CFLAGS="-Werror"
+-fi
+ # The entries after -Wno-pointer-sign are disabled warnings which may
+ # be enabled in the future, which can not currently be used to build
+ # GDB.
+ # NOTE: If you change this list, remember to update
+@@ -1352,11 +1349,10 @@ then
+     AC_MSG_CHECKING(compiler warning flags)
+     # Separate out the -Werror flag as some files just cannot be
+     # compiled with it enabled.
+     for w in ${build_warnings}; do
+       case $w in
+-      -Werr*) WERROR_CFLAGS=-Werror ;;
+       *) # Check that GCC accepts it
+           saved_CFLAGS="$CFLAGS"
+           CFLAGS="$CFLAGS $w"
+           AC_TRY_COMPILE([],[],WARN_CFLAGS="${WARN_CFLAGS} $w",)
+           CFLAGS="$saved_CFLAGS"
index 0c236925dc6947ea0ec455ddf6932a0c071658b1..bb3a28a1510d6993a676284a30cc9d347dea1a8a 100644 (file)
@@ -6,7 +6,8 @@ PRIORITY = "optional"
 
 inherit autotools
 
-SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
+           file://no-werror.patch;patch=1"
 
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gdb-${PV}"
 
index 1af156ca03aee386d374be3edaaf59ecd43c7124..c32c6cf1433c16a7413bf4109a23b76e8d2a59a3 100644 (file)
@@ -12,7 +12,7 @@ inherit gettext
 
 SRC_URI += "file://kill_arm_map_symbols.patch;patch=1 \
             file://gdbserver-cflags-last.diff;patch=1;pnum=0 \
-           file://ignore_whitespace_changes.patch;patch=1"
+                       file://ignore_whitespace_changes.patch;patch=1 "
 #FIXME    file://uclibc.patch;patch=1 \
 
 EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"