]> code.ossystems Code Review - openembedded-core.git/commitdiff
rpm: avoid dependency on perl and python for -native build
authorPhil Blundell <pb@pbcl.net>
Thu, 2 Jun 2011 09:48:27 +0000 (10:48 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Jun 2011 13:52:15 +0000 (14:52 +0100)
Update override naming (_native -> _virtclass-native) to disable perl
and python bindings when building native rpm, and adjust the DEPENDS to
match.

Perl bindings were, in fact, already disabled for both native and target
builds so it's only the python ones that have really changed.

Signed-off-by: Phil Blundell <philb@gnu.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/rpm/rpm_5.4.0.bb

index d3f85f22a1ecb71df24ad93dd33e6c85993ddcb4..5c30f1cbf7ad4885256825d26a0a12edd91e2258 100644 (file)
@@ -42,8 +42,10 @@ HOMEPAGE = "http://rpm5.org/"
 LICENSE = "LGPL 2.1"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
 
-DEPENDS = "bzip2 zlib python perl db openssl elfutils expat libpcre attr acl popt"
-PR = "r16"
+rpmdeps = "bzip2 zlib db openssl elfutils expat libpcre attr acl popt"
+DEPENDS = "${rpmdeps} python perl"
+DEPENDS_virtclass-native = "${rpmdeps}"
+PR = "r17"
 
 # rpm2cpio is a shell script, which is part of the rpm src.rpm.  It is needed
 # in order to extract the distribution SRPM into a format we can extract...
@@ -92,7 +94,7 @@ WITH_PYTHON = "       --with-python=${PYTHON_BASEVERSION} \
                --without-pythonembed \
              "
 
-WITH_PYTHON_native = " --without-python"
+WITH_PYTHON_virtclass-native = " --without-python"
 
 # Perl modules are not built, but they could be enabled fairly easily
 # the perl module creation and installation would need to be patched.
@@ -100,7 +102,7 @@ WITH_PYTHON_native = " --without-python"
 #WITH_PERL = " --with-perl --without-perlembed"
 WITH_PERL = "  --without-perl"
 
-WITH_PERL_native = " --without-perl"
+WITH_PERL_virtclass-native = " --without-perl"
 
 WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated --without-sqlite"