]> code.ossystems Code Review - openembedded-core.git/commitdiff
autoconf: Extend to provide nativesdk recipe
authorWenzong Fan <wenzong.fan@windriver.com>
Wed, 30 Nov 2011 08:45:44 +0000 (16:45 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Nov 2011 15:09:43 +0000 (15:09 +0000)
As the same reason with automake, extend autoconf to provide
nativesdk recipe too.

This patch was only used for autoconf that running on target:
    * path_prog_fixes.patch: replace '@PERL@' with '@bindir@/env perl'

It's unavailable for autoconf-native and autoconf-nativesdk, so
exclude it for those two recipes.

Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/autoconf/autoconf_2.68.bb

index 21b5fb3f24b791479d0ee9b89e615b09554b52f6..9028e8336b2152a253d7c78e8469cd909dc551f1 100644 (file)
@@ -1,6 +1,6 @@
 require autoconf.inc
 
-PR = "r3"
+PR = "r4"
 
 PARALLEL_MAKE = ""
 
@@ -14,7 +14,7 @@ SRC_URI += "file://autoreconf-include.patch \
            file://autoreconf-foreign.patch \
            file://autoreconf-gnuconfigize.patch \
            file://autoheader-nonfatal-warnings.patch \
-           ${@['file://path_prog_fixes.patch', ''][bb.data.inherits_class('native', d)]} \
+           ${@['file://path_prog_fixes.patch', ''][bb.data.inherits_class('native', d) or bb.data.inherits_class('nativesdk', d)]} \
             file://config_site.patch \
             file://remove-usr-local-lib-from-m4.patch \
            "
@@ -25,8 +25,11 @@ SRC_URI[sha256sum] = "c491fb273fd6d4ca925e26ceed3d177920233c76d542b150ff35e57145
 DEPENDS_virtclass-native = "m4-native gnu-config-native"
 RDEPENDS_${PN}_virtclass-native = "m4-native gnu-config-native"
 
+DEPENDS_virtclass-nativesdk = "m4-nativesdk gnu-config-nativesdk"
+RDEPENDS_${PN}_virtclass-nativesdk = "m4-nativesdk gnu-config-nativesdk"
+
 SRC_URI_append_virtclass-native = " file://fix_path_xtra.patch"
 
 EXTRA_OECONF += "ac_cv_path_M4=m4"
 
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"