]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnu-efi: fix the LIBDIR
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 27 Mar 2014 06:09:46 +0000 (14:09 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 27 Mar 2014 15:44:16 +0000 (15:44 +0000)
Its LIBDIR in Makefile is:

LIBDIR = $(PREFIX)/lib

This is incorrect for 64 bit bsp, thus will cause build failures on gummiboot:

ld: cannot open linker script file /path/to/usr/lib64/elf_x86_64_efi.lds: No such file or directory

[YOCTO #6053]

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-bsp/gnu-efi/gnu-efi_3.0u.bb

index 0dbdba27ac13acc40d4e32acbdce4afdcdcb7056..dbf2a07a8a44096860f4cc7928bc33d2ce1a391b 100644 (file)
@@ -23,7 +23,7 @@ def gnu_efi_arch(d):
     return tarch
 
 EXTRA_OEMAKE = "'ARCH=${@gnu_efi_arch(d)}' 'CC=${CC}' 'AS=${AS}' 'LD=${LD}' 'AR=${AR}' \
-                'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}'\
+                'RANLIB=${RANLIB}' 'OBJCOPY=${OBJCOPY}' 'PREFIX=${prefix}' 'LIBDIR=${libdir}' \
                 "
 
 do_install() {