-Index: git/configure.in
+Index: offscreen/configure.in
===================================================================
---- git.orig/configure.in 2009-01-27 16:11:22.000000000 +0000
-+++ git/configure.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/configure.in 2009-04-16 22:51:48.000000000 +0100
++++ offscreen/configure.in 2009-04-16 23:07:48.000000000 +0100
@@ -62,7 +62,6 @@
AC_PREREQ(2.13)
dnl Set the version number of the libs included with mozilla
dnl ========================================================
-@@ -137,6 +135,9 @@
+@@ -136,6 +134,9 @@
MSMANIFEST_TOOL=
dnl Set various checks
dnl ========================================================
MISSING_X=
-@@ -263,7 +264,7 @@
+@@ -281,7 +282,7 @@
;;
esac
echo "cross compiling from $host to $target"
cross_compiling=yes
-@@ -301,7 +302,7 @@
+@@ -319,7 +320,7 @@
AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
CC="$HOST_CXX"
-@@ -309,7 +310,7 @@
+@@ -327,7 +328,7 @@
AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
CC=$_SAVE_CC
-@@ -330,7 +331,7 @@
+@@ -348,7 +349,7 @@
;;
esac
unset ac_cv_prog_CC
AC_PROG_CC
AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
-@@ -354,37 +355,7 @@
+@@ -372,37 +373,6 @@
AC_CHECK_PROGS(STRIP, $STRIP "${target_alias}-strip" "${target}-strip", :)
AC_CHECK_PROGS(WINDRES, $WINDRES "${target_alias}-windres" "${target}-windres", :)
AC_DEFINE(CROSS_COMPILE)
- AC_PROG_CC
- AC_PROG_CXX
- AC_PROG_RANLIB
-- AC_PATH_PROGS(AS, $AS as, $CC)
+- MOZ_PATH_PROGS(AS, $AS as, $CC)
- AC_CHECK_PROGS(AR, ar, :)
- AC_CHECK_PROGS(LD, ld, :)
- AC_CHECK_PROGS(STRIP, strip, :)
- HOST_AR="$AR"
- fi
-fi
-+
GNU_AS=
GNU_LD=
-@@ -1467,6 +1438,7 @@
+@@ -1569,6 +1539,7 @@
'
dnl test that the macros actually work:
AC_MSG_CHECKING(that static assertion macros used in autoconf tests work)
AC_CACHE_VAL(ac_cv_static_assertion_macros_work,
[AC_LANG_SAVE
-@@ -2625,9 +2597,13 @@
+@@ -2730,9 +2701,13 @@
AC_LANG_C
AC_HEADER_STDC
AC_C_CONST
AC_TYPE_SIZE_T
AC_STRUCT_ST_BLKSIZE
AC_MSG_CHECKING(for siginfo_t)
-@@ -3009,19 +2985,9 @@
+@@ -3115,19 +3090,9 @@
dnl We don't want to link against libm or libpthread on Darwin since
dnl they both are just symlinks to libSystem and explicitly linking
dnl against libSystem causes issues when debugging (see bug 299601).
_SAVE_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -D_GNU_SOURCE"
-@@ -6763,18 +6729,13 @@
+@@ -6931,18 +6896,13 @@
# Demangle only for debug or trace-malloc builds
MOZ_DEMANGLE_SYMBOLS=
dnl ========================================================
dnl =
-@@ -7288,10 +7249,7 @@
+@@ -7454,10 +7414,7 @@
dnl if no gtk/libIDL1 or gtk2/libIDL2 combination was found, fall back
dnl to either libIDL1 or libIDL2.
if test -z "$_LIBIDL_FOUND"; then
fi
dnl
dnl If we don't have a libIDL config program & not cross-compiling,
-@@ -7364,11 +7322,7 @@
+@@ -7529,13 +7486,7 @@
+ fi
if test -z "$SKIP_PATH_CHECKS"; then
- if test -z "${GLIB_CFLAGS}" || test -z "${GLIB_LIBS}" ; then
+-if test -z "${GLIB_CFLAGS}" || test -z "${GLIB_LIBS}" ; then
- if test "$MOZ_ENABLE_GTK2" || test "$USE_ELF_DYNSTR_GC" || test "$MOZ_ENABLE_HEADLESS"; then
PKG_CHECK_MODULES(GLIB, glib-2.0 >= 1.3.7 gobject-2.0)
- else
- AM_PATH_GLIB(${GLIB_VERSION})
- fi
- fi
+-fi
fi
-@@ -8214,10 +8168,7 @@
+ if test -z "${GLIB_GMODULE_LIBS}" -a -n "${GLIB_CONFIG}"; then
+@@ -8346,10 +8297,7 @@
HAVE_WCRTOMB
"
)
# Save the defines header file before autoconf removes it.
-@@ -8276,28 +8227,9 @@
+@@ -8408,31 +8356,11 @@
dnl To add new Makefiles, edit allmakefiles.sh.
dnl allmakefiles.sh sets the variable, MAKEFILES.
. ${srcdir}/allmakefiles.sh
-. ./conftest.sh
-rm conftest.sh
--echo $MAKEFILES > unallmakefiles
+ echo $MAKEFILES > unallmakefiles
--AC_OUTPUT($MAKEFILES)
-+echo $MAKEFILES > unallmakefiles
+ mv -f config/autoconf.mk config/autoconf.mk.orig 2> /dev/null
+-AC_OUTPUT($MAKEFILES)
+-
dnl Prevent the regeneration of cairo-features.h forcing rebuilds of gfx stuff
if test "$CAIRO_FEATURES_H"; then
-@@ -8323,14 +8255,14 @@
+ if cmp -s $CAIRO_FEATURES_H "$CAIRO_FEATURES_H".orig; then
+@@ -8458,14 +8386,14 @@
HOST_LDFLAGS="$_SUBDIR_HOST_LDFLAGS"
RC=
if test -z "$MOZ_DEBUG"; then
ac_configure_args="$ac_configure_args --disable-debug"
fi
-@@ -8346,8 +8278,7 @@
+@@ -8481,8 +8409,7 @@
if test -n "$USE_ARM_KUSER"; then
ac_configure_args="$ac_configure_args --with-arm-kuser"
fi
fi
if test -z "$MOZ_NATIVE_NSPR"; then
-@@ -8364,7 +8295,6 @@
+@@ -8499,7 +8426,6 @@
# Run the SpiderMonkey 'configure' script.
dist=$MOZ_BUILD_ROOT/dist
ac_configure_args="$ac_configure_args --enable-threadsafe"
if test -z "$MOZ_NATIVE_NSPR"; then
ac_configure_args="$ac_configure_args --with-nspr-cflags='$NSPR_CFLAGS'"
-@@ -8378,7 +8308,11 @@
+@@ -8513,11 +8439,14 @@
if test "$MOZ_MEMORY"; then
ac_configure_args="$ac_configure_args --enable-jemalloc"
fi
+AC_CONFIG_SUBDIRS(js/src)
fi # COMPILE_ENVIRONMENT && !LIBXUL_SDK_DIR
-+
+
+m4_pattern_allow(AS_BIN)
+
+AC_OUTPUT($MAKEFILES)
+
-Index: git/js/src/configure.in
+ dnl Prevent the regeneration of autoconf.mk forcing rebuilds of the world
+ dnl Needs to be at the end to respect possible changes from NSPR configure
+ if cmp -s config/autoconf.mk config/autoconf.mk.orig; then
+Index: offscreen/js/src/configure.in
===================================================================
---- git.orig/js/src/configure.in 2009-01-27 16:11:53.000000000 +0000
-+++ git/js/src/configure.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/js/src/configure.in 2009-04-16 22:51:49.000000000 +0100
++++ offscreen/js/src/configure.in 2009-04-16 23:06:42.000000000 +0100
@@ -62,7 +62,6 @@
AC_PREREQ(2.13)
dnl Set various checks
dnl ========================================================
MISSING_X=
-@@ -201,7 +205,7 @@
+@@ -200,7 +204,7 @@
if test "$COMPILE_ENVIRONMENT"; then
echo "cross compiling from $host to $target"
_SAVE_CC="$CC"
-@@ -238,7 +242,7 @@
+@@ -237,7 +241,7 @@
AC_MSG_CHECKING([whether the host c compiler ($HOST_CC $HOST_CFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CC cannot create executables.]) )
CC="$HOST_CXX"
-@@ -246,7 +250,7 @@
+@@ -245,7 +249,7 @@
AC_MSG_CHECKING([whether the host c++ compiler ($HOST_CXX $HOST_CXXFLAGS $HOST_LDFLAGS) works])
AC_TRY_COMPILE([], [return(0);],
AC_MSG_ERROR([installation or configuration problem: host compiler $HOST_CXX cannot create executables.]) )
CC=$_SAVE_CC
-@@ -267,7 +271,7 @@
+@@ -266,7 +270,7 @@
;;
esac
unset ac_cv_prog_CC
AC_PROG_CC
AC_CHECK_PROGS(CXX, $CXX "${target_alias}-g++" "${target}-g++", :)
-@@ -297,37 +301,6 @@
+@@ -296,37 +300,6 @@
dnl able to run ppc code in a translated environment, making a cross
dnl compiler appear native. So we override that here.
cross_compiling=yes
- AC_PROG_CC
- AC_PROG_CXX
- AC_PROG_RANLIB
-- AC_PATH_PROGS(AS, $AS as, $CC)
+- MOZ_PATH_PROGS(AS, $AS as, $CC)
- AC_CHECK_PROGS(AR, ar, :)
- AC_CHECK_PROGS(LD, ld, :)
- AC_CHECK_PROGS(STRIP, strip, :)
GNU_AS=
GNU_LD=
-@@ -1396,6 +1369,8 @@
+@@ -1435,6 +1408,8 @@
fi # GNU_CC
fi # COMPILE_ENVIRONMENT
dnl =================================================================
dnl Set up and test static assertion macros used to avoid AC_TRY_RUN,
dnl which is bad when cross compiling.
-@@ -2524,9 +2499,13 @@
+@@ -2565,9 +2540,13 @@
AC_LANG_C
AC_HEADER_STDC
AC_C_CONST
AC_TYPE_SIZE_T
AC_STRUCT_ST_BLKSIZE
AC_MSG_CHECKING(for siginfo_t)
-@@ -2551,7 +2530,8 @@
+@@ -2592,7 +2571,8 @@
AC_CHECK_HEADER(stdint.h)
if test "$ac_cv_header_stdint_h" = yes; then
else
dnl We'll figure them out for ourselves. List more likely types
dnl earlier. If we ever really encounter a size for which none of
-@@ -2937,10 +2917,7 @@
+@@ -2990,10 +2970,7 @@
;;
*)
AC_CHECK_LIB(m, atan)
;;
esac
-@@ -3839,6 +3816,7 @@
+@@ -3908,6 +3885,7 @@
[ --with-nspr-libs=LIBS Pass LIBS to LD when linking code that uses NSPR.
See --with-nspr-cflags for more details.],
NSPR_LIBS=$withval)
AC_SUBST(NSPR_CFLAGS)
AC_SUBST(NSPR_LIBS)
-@@ -4467,18 +4445,11 @@
+@@ -4542,18 +4520,11 @@
# Demangle only for debug or trace-malloc builds
MOZ_DEMANGLE_SYMBOLS=
dnl ========================================================
dnl =
-@@ -5161,6 +5132,8 @@
+@@ -5256,6 +5227,8 @@
done
AC_SUBST(LIBS_PATH)
dnl ========================================================
dnl JavaScript shell
dnl ========================================================
-@@ -5292,3 +5265,4 @@
+@@ -5396,3 +5369,4 @@
# 'js-config' in Makefile.in.
AC_MSG_RESULT(invoking make to create js-config script)
$MAKE js-config
+
-Index: git/nsprpub/configure.in
+Index: offscreen/nsprpub/configure.in
===================================================================
---- git.orig/nsprpub/configure.in 2009-01-27 16:12:40.000000000 +0000
-+++ git/nsprpub/configure.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/nsprpub/configure.in 2009-04-16 18:09:00.000000000 +0100
++++ offscreen/nsprpub/configure.in 2009-04-16 23:06:42.000000000 +0100
@@ -42,7 +42,6 @@
AC_PREREQ(2.12)
AC_INIT(config/libc_r.h)
dnl ========================================================
dnl Check for gcc -pipe support
-@@ -2254,10 +2226,7 @@
+@@ -2249,10 +2221,7 @@
*-darwin*|*-beos*)
;;
*)
esac
-@@ -2874,6 +2843,8 @@
+@@ -2869,6 +2838,8 @@
dnl pr/tests/w16gui/Makefile
dnl tools/Makefile
if test -z "$USE_PTHREADS" && test -z "$USE_BTHREADS"; then
MAKEFILES="$MAKEFILES pr/src/threads/combined/Makefile"
elif test -n "$USE_PTHREADS"; then
-@@ -2889,3 +2860,5 @@
+@@ -2884,3 +2855,5 @@
echo $MAKEFILES > unallmakefiles
AC_OUTPUT([$MAKEFILES], [chmod +x config/nspr-config])
+
+
-Index: git/toolkit/toolkit-makefiles.sh
+Index: offscreen/toolkit/toolkit-makefiles.sh
===================================================================
---- git.orig/toolkit/toolkit-makefiles.sh 2009-01-27 16:13:11.000000000 +0000
-+++ git/toolkit/toolkit-makefiles.sh 2009-01-27 16:16:45.000000000 +0000
-@@ -632,7 +632,6 @@
+--- offscreen.orig/toolkit/toolkit-makefiles.sh 2009-04-16 22:51:50.000000000 +0100
++++ offscreen/toolkit/toolkit-makefiles.sh 2009-04-16 23:06:42.000000000 +0100
+@@ -628,7 +628,6 @@
toolkit/crashreporter/client/Makefile
toolkit/crashreporter/google-breakpad/src/client/Makefile
toolkit/crashreporter/google-breakpad/src/client/mac/handler/Makefile
toolkit/crashreporter/google-breakpad/src/client/windows/handler/Makefile
toolkit/crashreporter/google-breakpad/src/client/windows/sender/Makefile
toolkit/crashreporter/google-breakpad/src/common/Makefile
-Index: git/js/src/Makefile.in
+Index: offscreen/js/src/Makefile.in
===================================================================
---- git.orig/js/src/Makefile.in 2009-01-27 16:11:52.000000000 +0000
-+++ git/js/src/Makefile.in 2009-01-27 16:16:45.000000000 +0000
-@@ -513,20 +513,8 @@
+--- offscreen.orig/js/src/Makefile.in 2009-04-16 18:07:56.000000000 +0100
++++ offscreen/js/src/Makefile.in 2009-04-16 23:06:42.000000000 +0100
+@@ -507,20 +507,8 @@
export:: jsautocfg.h
--ifeq (,$(CROSS_COMPILE)$(filter-out WINNT,$(OS_ARCH)))
+-ifeq (,$(CROSS_COMPILE)$(GNU_CC)$(filter-out WINNT,$(OS_ARCH)))
jsautocfg.h:
touch $@
-else
# jscpucfg is a strange target
# Needs to be built with the host compiler but needs to include
-@@ -556,7 +544,7 @@
+@@ -550,7 +538,7 @@
echo no need to build jscpucfg $<
else
jscpucfg$(HOST_BIN_SUFFIX): jscpucfg.cpp Makefile.in
endif
endif
-Index: git/js/src/xpconnect/loader/mozJSComponentLoader.cpp
+Index: offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp
===================================================================
---- git.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-01-27 16:11:55.000000000 +0000
-+++ git/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-04-16 18:08:00.000000000 +0100
++++ offscreen/js/src/xpconnect/loader/mozJSComponentLoader.cpp 2009-04-16 23:06:42.000000000 +0100
@@ -47,6 +47,8 @@
#include <stdarg.h>
#include "prlog.h"
#include "nsCOMPtr.h"
-Index: git/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
+Index: offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp
===================================================================
---- git.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-01-27 16:11:55.000000000 +0000
-+++ git/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-04-16 18:08:00.000000000 +0100
++++ offscreen/js/src/xpconnect/loader/mozJSSubScriptLoader.cpp 2009-04-16 23:06:42.000000000 +0100
@@ -39,6 +39,8 @@
*
* ***** END LICENSE BLOCK ***** */
#if !defined(XPCONNECT_STANDALONE) && !defined(NO_SUBSCRIPT_LOADER)
#include "mozJSSubScriptLoader.h"
-Index: git/modules/lcms/include/icc34.h
+Index: offscreen/modules/lcms/include/icc34.h
===================================================================
---- git.orig/modules/lcms/include/icc34.h 2009-01-27 16:12:31.000000000 +0000
-+++ git/modules/lcms/include/icc34.h 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/modules/lcms/include/icc34.h 2009-04-16 18:08:47.000000000 +0100
++++ offscreen/modules/lcms/include/icc34.h 2009-04-16 23:06:42.000000000 +0100
@@ -144,7 +144,7 @@
*/
/*
June 9, 2003, Adapted for use with configure by Bob Friesenhahn
Added the stupid check for autoconf by Marti Maria.
-Index: git/toolkit/mozapps/update/src/updater/Makefile.in
+Index: offscreen/toolkit/mozapps/update/src/updater/Makefile.in
===================================================================
---- git.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-01-27 16:13:09.000000000 +0000
-+++ git/toolkit/mozapps/update/src/updater/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/toolkit/mozapps/update/src/updater/Makefile.in 2009-04-16 18:09:35.000000000 +0100
++++ offscreen/toolkit/mozapps/update/src/updater/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -59,7 +59,7 @@
LIBS += \
$(NULL)
ifeq ($(OS_ARCH),WINNT)
-Index: git/xpcom/sample/program/Makefile.in
+Index: offscreen/xpcom/sample/program/Makefile.in
===================================================================
---- git.orig/xpcom/sample/program/Makefile.in 2009-01-27 16:13:18.000000000 +0000
-+++ git/xpcom/sample/program/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/xpcom/sample/program/Makefile.in 2009-04-16 18:09:47.000000000 +0100
++++ offscreen/xpcom/sample/program/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -57,7 +57,7 @@
# that the application be linked against the XPCOM dynamic library or the NSPR
# dynamic libraries.
$(NULL)
# Need to link with CoreFoundation on Mac
-Index: git/xpcom/tools/registry/Makefile.in
+Index: offscreen/xpcom/tools/registry/Makefile.in
===================================================================
---- git.orig/xpcom/tools/registry/Makefile.in 2009-01-27 16:13:18.000000000 +0000
-+++ git/xpcom/tools/registry/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/xpcom/tools/registry/Makefile.in 2009-04-16 18:09:48.000000000 +0100
++++ offscreen/xpcom/tools/registry/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -54,7 +54,7 @@
SIMPLE_PROGRAMS = $(CPPSRCS:.cpp=$(BIN_SUFFIX))
$(NULL)
# Need to link with CoreFoundation on Mac
-Index: git/xulrunner/app/Makefile.in
+Index: offscreen/xulrunner/app/Makefile.in
===================================================================
---- git.orig/xulrunner/app/Makefile.in 2009-01-27 16:13:19.000000000 +0000
-+++ git/xulrunner/app/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/xulrunner/app/Makefile.in 2009-04-16 18:09:50.000000000 +0100
++++ offscreen/xulrunner/app/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -180,7 +180,7 @@
RCFLAGS += -DXULRUNNER_ICO=\"$(DIST)/branding/xulrunner.ico\" -DDOCUMENT_ICO=\"$(DIST)/branding/document.ico\"
endif
include $(topsrcdir)/config/rules.mk
-Index: git/xulrunner/stub/Makefile.in
+Index: offscreen/xulrunner/stub/Makefile.in
===================================================================
---- git.orig/xulrunner/stub/Makefile.in 2009-01-27 16:13:20.000000000 +0000
-+++ git/xulrunner/stub/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/xulrunner/stub/Makefile.in 2009-04-16 18:09:50.000000000 +0100
++++ offscreen/xulrunner/stub/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -101,7 +101,7 @@
endif
endif
include $(topsrcdir)/config/rules.mk
-Index: git/modules/plugin/test/testplugin/Makefile.in
+Index: offscreen/modules/plugin/test/testplugin/Makefile.in
===================================================================
---- git.orig/modules/plugin/test/testplugin/Makefile.in 2009-01-27 16:12:37.000000000 +0000
-+++ git/modules/plugin/test/testplugin/Makefile.in 2009-01-27 16:16:45.000000000 +0000
+--- offscreen.orig/modules/plugin/test/testplugin/Makefile.in 2009-04-16 18:08:56.000000000 +0100
++++ offscreen/modules/plugin/test/testplugin/Makefile.in 2009-04-16 23:06:42.000000000 +0100
@@ -63,9 +63,7 @@
CMMSRCS = nptest_macosx.mm
endif
CPPSRCS += nptest_gtk2.cpp
-endif
- ifeq ($(MOZ_WIDGET_TOOLKIT),windows)
- CPPSRCS += nptest_windows.cpp
-Index: git/xulrunner/installer/libxul-unstable.pc.in
+ ifeq ($(MOZ_WIDGET_TOOLKIT),qt)
+ CPPSRCS += nptest_qt.cpp
+Index: offscreen/xulrunner/installer/libxul-unstable.pc.in
===================================================================
---- git.orig/xulrunner/installer/libxul-unstable.pc.in 2009-01-27 18:07:55.000000000 +0000
-+++ git/xulrunner/installer/libxul-unstable.pc.in 2009-01-28 15:19:22.000000000 +0000
+--- offscreen.orig/xulrunner/installer/libxul-unstable.pc.in 2009-04-16 18:09:50.000000000 +0100
++++ offscreen/xulrunner/installer/libxul-unstable.pc.in 2009-04-16 23:06:42.000000000 +0100
@@ -8,5 +8,5 @@
Description: The Mozilla Runtime and Embedding Engine (unstable API)
Version: %MOZILLA_VERSION%
-Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom
+Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom -lsmime3 -lnss3 -lssl3 -lnssutil3 -L${sdkdir}/../xulrunner-1.9.2a1pre
Cflags: -I${includedir}/${includetype} %WCHAR_CFLAGS%
+Index: offscreen/js/src/aclocal.m4
+===================================================================
+--- offscreen.orig/js/src/aclocal.m4 2009-04-16 18:07:56.000000000 +0100
++++ offscreen/js/src/aclocal.m4 2009-04-16 23:06:42.000000000 +0100
+@@ -9,4 +9,3 @@
+ builtin(include, build/autoconf/moznbytetype.m4)dnl
+ builtin(include, build/autoconf/mozprog.m4)dnl
+
+-MOZ_PROG_CHECKMSYS()