]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-omap: fix build failure with gcc-4.3.3
authorDexuan Cui <dexuan.cui@intel.com>
Wed, 23 Jun 2010 05:51:15 +0000 (13:51 +0800)
committerDexuan Cui <dexuan.cui@intel.com>
Wed, 23 Jun 2010 06:41:25 +0000 (14:41 +0800)
Pull time.h patch from upstream Linux kernel
(commit 38332cb98772f5ea757e6486bed7ed0381cb5f98)

The patch fixes the following build failure:
  LD      .tmp_vmlinux1
kernel/built-in.o: In function `timespec_add_ns':
    undefined reference to `__aeabi_uldivmod'
kernel/built-in.o: In function `do_gettimeofday':
    undefined reference to `__aeabi_uldivmod'
    undefined reference to `__aeabi_uldivmod'
kernel/built-in.o: In function `timespec_add_ns':
    undefined reference to `__aeabi_uldivmod'
    undefined reference to `__aeabi_uldivmod'
kernel/built-in.o: more undefined references to `__aeabi_uldivmod'

Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
meta/packages/linux/linux-omap-2.6.24.7/time-prevent-the-loop-in-timespec_add_ns-from-being-optimised-away.patch [new file with mode: 0644]
meta/packages/linux/linux-omap_2.6.24.7.bb

diff --git a/meta/packages/linux/linux-omap-2.6.24.7/time-prevent-the-loop-in-timespec_add_ns-from-being-optimised-away.patch b/meta/packages/linux/linux-omap-2.6.24.7/time-prevent-the-loop-in-timespec_add_ns-from-being-optimised-away.patch
new file mode 100644 (file)
index 0000000..58cbe7b
--- /dev/null
@@ -0,0 +1,29 @@
+commit 38332cb98772f5ea757e6486bed7ed0381cb5f98
+Author: Segher Boessenkool <segher@kernel.crashing.org>
+Date:   Tue Mar 4 14:59:54 2008 -0800
+
+    time: prevent the loop in timespec_add_ns() from being optimised away
+    
+    Since some architectures don't support __udivdi3().
+    
+    Signed-off-by: Segher Boessenkool <segher@kernel.crashing.org>
+    Cc: john stultz <johnstul@us.ibm.com>
+    Cc: Ingo Molnar <mingo@elte.hu>
+    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
+    Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
+
+diff --git a/include/linux/time.h b/include/linux/time.h
+index 2091a19..d32ef0a 100644
+--- a/include/linux/time.h
++++ b/include/linux/time.h
+@@ -174,6 +174,10 @@ static inline void timespec_add_ns(struct timespec *a, u64 ns)
+ {
+       ns += a->tv_nsec;
+       while(unlikely(ns >= NSEC_PER_SEC)) {
++              /* The following asm() prevents the compiler from
++               * optimising this loop into a modulo operation.  */
++              asm("" : "+r"(ns));
++
+               ns -= NSEC_PER_SEC;
+               a->tv_sec++;
+       }
index 1cdad0db5eb89d14c7e7fa24fb0e6e69e6137502..1defa79c50e8b7454d8a93de403fe0b7b563a2f5 100644 (file)
@@ -1,6 +1,6 @@
 require linux-omap.inc
 
-PR = "r5"
+PR = "r6"
 
 COMPATIBLE_MACHINE = "omap-3430ldp|omap-3430sdp"
 DEFAULT_PREFERENCE = "1"
@@ -18,6 +18,7 @@ SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
          file://fixes.patch;patch=1 \
          file://fixes2.patch;patch=1 \
          file://module_fix.patch;patch=1 \
+         file://time-prevent-the-loop-in-timespec_add_ns-from-being-optimised-away.patch;patch=1 \
          file://defconfig-${MACHINE}"
 
 S = "${WORKDIR}/linux-2.6.24"