]> code.ossystems Code Review - openembedded-core.git/commitdiff
libedit: fix failed to get history
authorChangqing Li <changqing.li@windriver.com>
Fri, 23 Aug 2019 01:55:45 +0000 (09:55 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 27 Aug 2019 21:52:41 +0000 (22:52 +0100)
Reproduce steps:
run fileman under examples, history command not work,
nothing is output.

Fix by increase history_offset when add history, if not,
it will make current history event not align with offset,
and cannot get history correctly.

Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/libedit/libedit/0001-readline.c-fix-cannot-get-history.patch [new file with mode: 0644]
meta/recipes-devtools/libedit/libedit_20190324-3.1.bb

diff --git a/meta/recipes-devtools/libedit/libedit/0001-readline.c-fix-cannot-get-history.patch b/meta/recipes-devtools/libedit/libedit/0001-readline.c-fix-cannot-get-history.patch
new file mode 100644 (file)
index 0000000..7e54ac9
--- /dev/null
@@ -0,0 +1,34 @@
+From ef1fa9bef497d9491a51017f3cad0135a23bb0b4 Mon Sep 17 00:00:00 2001
+From: Changqing Li <changqing.li@windriver.com>
+Date: Tue, 20 Aug 2019 17:33:15 +0800
+Subject: [PATCH] readline.c: fix cannot get history
+
+if history_offset not increate when add history,
+it will make current history event not align with offset,
+and cannot get history correctly.
+
+Upstream-Status: Submitted [tech-userlevel@NetBSD.org] 
+
+Signed-off-by: Changqing Li <changqing.li@windriver.com>
+---
+ src/readline.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/readline.c b/src/readline.c
+index 43ac5bd..54b0548 100644
+--- a/src/readline.c
++++ b/src/readline.c
+@@ -1476,7 +1476,10 @@ add_history(const char *line)
+       if (ev.num == history_length)
+               history_base++;
+       else
++        {
++                history_offset++;
+               history_length = ev.num;
++        }
+       return 0;
+ }
+-- 
+2.7.4
+
index 6a599ebca55b2ec4bb08d80ebd4212de8962d7ee..858554118686ca7fd00568e011fa81b2259bc0ab 100644 (file)
@@ -14,6 +14,7 @@ inherit autotools
 FETCHCMD_wget += "-U bitbake"
 SRC_URI = "http://www.thrysoee.dk/editline/${BP}.tar.gz \
            file://stdc-predef.patch \
+           file://0001-readline.c-fix-cannot-get-history.patch \
           "
 SRC_URI[md5sum] = "bec755c8044ad84b752dfe49a0b371d8"
 SRC_URI[sha256sum] = "ac8f0f51c1cf65492e4d1e3ed2be360bda41e54633444666422fbf393bba1bae"