]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-poky: Allow the cursor to be shown when using qemuarm
authorRichard Purdie <richard@openedhand.com>
Mon, 22 May 2006 22:13:36 +0000 (22:13 +0000)
committerRichard Purdie <richard@openedhand.com>
Mon, 22 May 2006 22:13:36 +0000 (22:13 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@404 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/matchbox-poky/matchbox-poky/etc/matchbox/session
openembedded/packages/matchbox-poky/matchbox-poky_0.1.bb

index 2806094a796d5aad57760b8f9b242aac3c10204a..fede9e44b9dc6bbea08e1226116d4d51dd65de6d 100755 (executable)
@@ -4,6 +4,8 @@ module_id() {
     awk 'BEGIN { FS=": " } /Hardware/ { print $2 } ' </proc/cpuinfo
 }
 
+SHOWCURSOR="no"
+
 ## Start up machine specific input devices. Really needs to go in its own session
 case `module_id` in
        "SHARP Shepherd" | "SHARP Husky" | "SHARP Corgi" | "SHARP Spitz" | "SHARP Akita" | "SHARP Borzoi")
@@ -12,6 +14,10 @@ case `module_id` in
        "Generic OMAP1510/1610/1710")
                /usr/bin/mbinputmgr &
                ;;
+       "ARM-IntegratorCP")
+               /usr/bin/mbinputmgr &
+               SHOWCURSOR="yes"
+               ;;
 esac
 
 ## All this should be done by themeing/xsettings.. ## 
@@ -32,6 +38,6 @@ matchbox-panel --orientation east \
                --default-apps mb-applet-home,mb-applet-clock,mb-applet-battery &
 
 ## eek ugly no cursor hack - transparent theme should do this
-exec matchbox-window-manager -theme Clearlooks -use_cursor no $@
+exec matchbox-window-manager -theme Clearlooks -use_cursor $SHOWCURSOR $@
 
 
index 5cc114666bf4befb0d7b747cc0c185b895bed0b2..c2e3e3282c1a97669ddd02e758e2e2ecf5e381cd 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Custom MB session files for poky"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "matchbox matchbox-applet-startup-monitor gtk-theme-clearlooks"
-PR = "r12"
+PR = "r13"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}