]> code.ossystems Code Review - openembedded-core.git/commitdiff
libacpi: Remove QA warning: No GNU_HASH in the elf binary
authorMuhammad Shakeel <muhammad_shakeel@mentor.com>
Wed, 12 Dec 2012 11:35:41 +0000 (16:35 +0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Dec 2012 14:48:13 +0000 (14:48 +0000)
Handle LDFLAGS properly in the Makefile to remove warning:
QA Issue: No GNU_HASH in the elf binary

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/libacpi/files/ldflags.patch [new file with mode: 0644]
meta/recipes-bsp/libacpi/libacpi_0.2.bb

diff --git a/meta/recipes-bsp/libacpi/files/ldflags.patch b/meta/recipes-bsp/libacpi/files/ldflags.patch
new file mode 100644 (file)
index 0000000..a7424c3
--- /dev/null
@@ -0,0 +1,41 @@
+libacpi: Remove QA warning: No GNU_HASH in the elf binary
+
+Upstream-Status: Inappropriate [other]
+  Useful within bitbake environment only.
+
+Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
+
+---
+ Makefile  |    3 ++-
+ config.mk |    1 +
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+--- libacpi-0.2.orig/Makefile
++++ libacpi-0.2/Makefile
+@@ -19,6 +19,7 @@ options:
+       @echo "CFLAGS   = ${CFLAGS}"
+       @echo "CC       = ${CC}"
+       @echo "SOFLAGS  = ${SOFLAGS}"
++      @echo "LDFLAGS  = ${LDFLAGS}"
+       @echo "LD       = ${LD}"
+ .c.o:
+@@ -34,7 +35,7 @@ libacpi.a: ${OBJ}
+ libacpi.so: ${OBJ}
+       @echo LD $@
+-      @${CC} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
++      @${CC} ${SOFLAGS} ${LDFLAGS} -o $@.${SOVERSION} ${OBJ}
+ test-libacpi: ${OBJ_test}
+       @echo LD $@
+--- libacpi-0.2.orig/config.mk
++++ libacpi-0.2/config.mk
+@@ -10,6 +10,7 @@ MANPREFIX = ${PREFIX}/share/man
+ SOFLAGS = -shared -Wl,-soname,${SONAME}
+ CFLAGS += -fPIC -g --pedantic -Wall -Wextra
+ ARFLAGS = cr
++LDFLAGS =
+ # Compiler and linker
+ CC = cc
index b0fbf0b2072ed2737d3abcb84dcab996f97c9d27..f4c323d18b92e3b03df42874c99eebb241b97cdf 100644 (file)
@@ -10,7 +10,8 @@ PR = "r6"
 SRC_URI = "http://www.ngolde.de/download/libacpi-${PV}.tar.gz \
           file://makefile-fix.patch \
           file://libacpi_fix_for_x32.patch \
-          file://use_correct_strip_in_cross_environment.patch"
+          file://use_correct_strip_in_cross_environment.patch \
+          file://ldflags.patch "
 
 SRC_URI[md5sum] = "05b53dd7bead66dda35fec502b91066c"
 SRC_URI[sha256sum] = "13086e31d428b9c125954d48ac497b754bbbce2ef34ea29ecd903e82e25bad29"