]> code.ossystems Code Review - openembedded-core.git/commitdiff
python/python3: Whitelist CVE-2019-18348
authorAdrian Bunk <bunk@stusta.de>
Fri, 17 Jan 2020 17:04:21 +0000 (19:04 +0200)
committerArmin Kuster <akuster808@gmail.com>
Thu, 23 Jan 2020 02:14:57 +0000 (18:14 -0800)
This is not exploitable when glibc has CVE-2016-10739 fixed,
which is fixed in the upstream version since warrior.

Signed-off-by: Adrian Bunk <bunk@stusta.de>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python.inc
meta/recipes-devtools/python/python3_3.7.5.bb

index 5d280dc63be67380259a6212477f85244dcab46c..a2424a67bf6377b16fce701a38694d67c6df9f01 100644 (file)
@@ -29,6 +29,9 @@ CVE_CHECK_WHITELIST += "CVE-2017-18207"
 # of Python that cannot really be altered at this point."
 CVE_CHECK_WHITELIST += "CVE-2015-5652"
 
+# This is not exploitable when glibc has CVE-2016-10739 fixed.
+CVE_CHECK_WHITELIST += "CVE-2019-18348"
+
 PYTHON_MAJMIN = "2.7"
 
 inherit autotools pkgconfig
index c560c4a29d662ef34021296bd3ad4ed4eb360d26..c90054d45a8713b67cfe59c1ef525a6359b2f743 100644 (file)
@@ -46,6 +46,9 @@ UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
 
 CVE_PRODUCT = "python"
 
+# This is not exploitable when glibc has CVE-2016-10739 fixed.
+CVE_CHECK_WHITELIST += "CVE-2019-18348"
+
 PYTHON_MAJMIN = "3.7"
 PYTHON_BINABI = "${PYTHON_MAJMIN}m"