]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: add machine-id to conffiles
authorDan McGregor <dan.mcgregor@usask.ca>
Tue, 3 Nov 2015 22:54:35 +0000 (16:54 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 25 Nov 2015 08:01:32 +0000 (08:01 +0000)
If / is mounted read-write machine-id will be overwritten on first boot.
This change ensures that the machine-id file persists across package
upgrades to systemd.

Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/systemd/systemd_225.bb

index 0b54ac86f961b88efd66365dec8d18bc3a5d8892..6393ca0fef5cca08a8da39b807f6860b1fa42950 100644 (file)
@@ -270,7 +270,8 @@ RRECOMMENDS_${PN}-binfmt = "kernel-module-binfmt-misc"
 
 RRECOMMENDS_${PN}-vconsole-setup = "kbd kbd-consolefonts kbd-keymaps"
 
-CONFFILES_${PN} = "${sysconfdir}/systemd/journald.conf \
+CONFFILES_${PN} = "${sysconfdir}/machine-id \
+                ${sysconfdir}/systemd/journald.conf \
                 ${sysconfdir}/systemd/logind.conf \
                 ${sysconfdir}/systemd/system.conf \
                 ${sysconfdir}/systemd/user.conf"