]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: skip in non-systemd distros to fix world builds
authorRoss Burton <ross.burton@intel.com>
Mon, 21 Jan 2013 12:15:30 +0000 (12:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2013 12:43:38 +0000 (12:43 +0000)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd_196.bb

index 18614372364166055b899b086f900c4c7e93c298..85bb4f98842d0a5a208844f98068b69314905c61 100644 (file)
@@ -247,3 +247,11 @@ update-alternatives --remove reboot ${base_bindir}/systemctl
 update-alternatives --remove shutdown ${base_bindir}/systemctl
 update-alternatives --remove poweroff ${base_bindir}/systemctl
 }
+
+
+# As this recipe builds udev, respect the systemd DISTRO_FEATURE so we don't try
+# building udev and systemd in world builds.
+python () {
+    if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
+        raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+}