]> code.ossystems Code Review - openembedded-core.git/commitdiff
libacpi: First poky commit
authorSamuel Ortiz <sameo@openedhand.com>
Tue, 30 Sep 2008 09:46:20 +0000 (09:46 +0000)
committerSamuel Ortiz <sameo@openedhand.com>
Tue, 30 Sep 2008 09:46:20 +0000 (09:46 +0000)
This is a generic ACPI library for accessing ACPI data.

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5332 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/libacpi/files/makefile-fix.patch [new file with mode: 0644]
meta/packages/libacpi/libacpi_0.2.bb [new file with mode: 0644]

diff --git a/meta/packages/libacpi/files/makefile-fix.patch b/meta/packages/libacpi/files/makefile-fix.patch
new file mode 100644 (file)
index 0000000..9193929
--- /dev/null
@@ -0,0 +1,45 @@
+---
+ Makefile  |    6 +++---
+ config.mk |    3 ++-
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+Index: libacpi-0.2/Makefile
+===================================================================
+--- libacpi-0.2.orig/Makefile  2007-07-29 14:09:34.000000000 +0200
++++ libacpi-0.2/Makefile       2008-09-26 10:34:53.000000000 +0200
+@@ -25,16 +25,16 @@ ${OBJ}: config.mk libacpi.h
+ libacpi.a: ${OBJ}
+       @echo AR $@
+-      @${AR} $@ ${OBJ}
++      ${AR} ${ARFLAGS} $@ ${OBJ}
+       @${RANLIB} $@
+ libacpi.so: ${OBJ}
+       @echo LD $@
+-      @${LD} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
++      @${CC} ${SOFLAGS} -o $@.${SOVERSION} ${OBJ}
+ test-libacpi: ${OBJ_test}
+       @echo LD $@
+-      @${LD} -o $@ ${OBJ_test} ${LDFLAGS}
++      @${CC} -o $@ ${OBJ_test} ${LDFLAGS}
+       @strip $@
+ install: all
+Index: libacpi-0.2/config.mk
+===================================================================
+--- libacpi-0.2.orig/config.mk 2007-07-29 14:09:34.000000000 +0200
++++ libacpi-0.2/config.mk      2008-09-26 10:34:33.000000000 +0200
+@@ -9,9 +9,10 @@ MANPREFIX = ${PREFIX}/share/man
+ # flags
+ SOFLAGS = -shared -Wl,-soname,${SONAME}
+ CFLAGS += -fPIC -g --pedantic -Wall -Wextra
++ARFLAGS = cr
+ # Compiler and linker
+ CC = cc
+ LD = ${CC}
+-AR = ar cr
++AR = ar
+ RANLIB = ranlib
diff --git a/meta/packages/libacpi/libacpi_0.2.bb b/meta/packages/libacpi/libacpi_0.2.bb
new file mode 100644 (file)
index 0000000..ccb06f2
--- /dev/null
@@ -0,0 +1,19 @@
+DESCRIPTION = "ACPI data gathering library."
+SECTION = "base"
+HOMEPAGE = "http://www.ngolde.de/libacpi.html"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.ngolde.de/download/libacpi-${PV}.tar.gz \
+          file://makefile-fix.patch;patch=1 "
+
+FILES_${PN} = "${libdir}"
+FILES_libacpi-dev = "${includedir}"
+
+do_stage() {
+       install -m 0644 libacpi.h ${STAGING_INCDIR}
+       oe_libinstall -so libacpi ${STAGING_LIBDIR}
+}
+
+do_install() {
+       oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
+}