]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: install udev.pc
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 21 Jul 2016 03:35:53 +0000 (20:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 23 Sep 2016 17:06:10 +0000 (18:06 +0100)
It provides udev, but doesn't install udev.pc, which causes other
recipes failed to figure out udevdir.

Fixed when systemd in DISTRO_FEATURES:
$ bitbake pcmciautils (or btrfs-tools):

Package udev was not found in the pkg-config search path.
Perhaps you should add the directory containing `udev.pc'
to the PKG_CONFIG_PATH environment variable
No package 'udev' found

Their udev rules file may not be installed according to each pkg's
implementation.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
meta/recipes-core/systemd/systemd_230.bb

index 1276316a0cddeefecb34cf9422c94c3ed12f5381..a949fe8dbf712de484dbe68725d1badc73f70243 100644 (file)
@@ -200,6 +200,8 @@ do_install() {
        install -d ${D}${sysconfdir}/udev/rules.d/
        install -d ${D}${sysconfdir}/tmpfiles.d
        install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
+       install -d ${D}${libdir}/pkgconfig
+       install -m 0644 ${B}/src/udev/udev.pc ${D}${libdir}/pkgconfig/
 
        install -m 0644 ${WORKDIR}/00-create-volatile.conf ${D}${sysconfdir}/tmpfiles.d/