]> code.ossystems Code Review - openembedded-core.git/commitdiff
socat: support native compilation
authorPatrick Ohly <patrick.ohly@intel.com>
Mon, 23 Jan 2017 14:17:04 +0000 (15:17 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 26 Jan 2017 10:41:11 +0000 (10:41 +0000)
This is needed for building the swtpm TPM simulator (recipe
in meta-security).

Native compilation disables tcp-wrappers by default to simplify
the build.

"nativesdk" is added just in case that someone also wants this
in an SDK.

Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/socat/socat_1.7.3.1.bb

index 4da6d3970bf671815afef5bd722126e6572f677d..a579f1ef0f5a50ce9042e905ec4a939c40ac820e 100644 (file)
@@ -29,10 +29,13 @@ EXTRA_OECONF += "ac_cv_have_z_modifier=yes \
         ac_cv_header_bsd_libutil_h=no \
 "
 
-PACKAGECONFIG ??= "tcp-wrappers"
+PACKAGECONFIG_class-target ??= "tcp-wrappers"
+PACKAGECONFIG ??= ""
 PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
 
 do_install_prepend () {
     mkdir -p ${D}${bindir}
     install -d ${D}${bindir} ${D}${mandir}/man1
 }
+
+BBCLASSEXTEND = "native nativesdk"