]> code.ossystems Code Review - openembedded-core.git/commitdiff
binutils/glibc-testsuite: inherit nopackages to fix world builds
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Sep 2019 10:29:31 +0000 (11:29 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Sep 2019 11:44:25 +0000 (12:44 +0100)
These recipes don't need to generate packages but did contain the packaging tasks which
would be triggered by a world build. They showed warnings or errors. Simplest fix
is to remove the unneeded tasks with the nopackages class.

Also don't attempt stash_locales task

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glibc/glibc-testsuite_2.30.bb
meta/recipes-devtools/binutils/binutils-cross-testsuite_2.32.bb

index 88764d9e2ba06f4c62638901b05357ee7b162e47..64fa8d87df4c0dcd608d51029f5f32d68ffea267 100644 (file)
@@ -49,3 +49,5 @@ do_check () {
 }
 addtask do_check after do_compile
 
+inherit nopackages
+deltask do_stash_locale
index e62e64e8ae3ed657a0cd6505a78d28b51861ccc5..07a8e7c417717797807fec30e1aded3b2746a9bf 100644 (file)
@@ -9,6 +9,8 @@ DEPENDS += "binutils-native"
 deltask do_compile
 deltask do_install
 
+inherit nopackages
+
 do_configure[dirs] += "${B}/ld ${B}/bfd"
 do_configure() {
     # create config.h, oe enables initfini-array by default