]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa-dri-glsl-native: upgrade from 7.8.2 to 7.9
authorYu Ke <ke.yu@intel.com>
Sun, 28 Nov 2010 02:10:07 +0000 (10:10 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 2 Dec 2010 13:24:58 +0000 (05:24 -0800)
with the following changes
- add license checksum
- add dependency of talloc-native, because mesa 7.9 start to use talloc to manage its memory.

Signed-off-by: Yu Ke <ke.yu@intel.com>
meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb [moved from meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb with 58% similarity]

similarity index 58%
rename from meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.8.2.bb
rename to meta/recipes-graphics/mesa/mesa-dri-glsl-native_7.9.bb
index f6121c19a423c351090b8a923b6251b506bf6e27..ffc113bfa7e426652e8cdd891219232d34723793 100644 (file)
@@ -3,22 +3,23 @@ HOMEPAGE = "http://mesa3d.org"
 BUGTRACKER = "https://bugs.freedesktop.org"
 SECTION = "x11"
 LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://main.cpp;endline=22;md5=a12a9c0208ee64a07ce314dfed4c81eb"
 PR = "r0"
 
-DEPENDS = "makedepend-native"
+DEPENDS = "makedepend-native talloc-native"
 
 SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
 
-S = "${WORKDIR}/Mesa-7.8.2/src/glsl/"
+S = "${WORKDIR}/Mesa-${PV}/src/glsl"
 
 inherit native
 
 # use default config for native build
 do_configure_prepend() {
-       ln -s ${S}/../../configs/default ${S}/../../configs/current
+       ln -sf ${S}/../../configs/default ${S}/../../configs/current
 }
 
 do_install() {
        install -d ${D}/${bindir}
-       install -m 755 ${S}/apps/compile ${D}/${bindir}/glsl-compile
+       install -m 755 ${S}/glsl_compiler ${D}/${bindir}/
 }