]> code.ossystems Code Review - openembedded-core.git/commitdiff
diffutils: Remove rather bizzare gettext macros
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Oct 2012 13:52:21 +0000 (13:52 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Oct 2012 11:03:27 +0000 (12:03 +0100)
diffutils has a rather confused set of getext macros with different names and
strange conflicting version requirements. This patch removes the problematic
macros allowing it to 'gettextize' to the latest standard gettext code without
issue.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/diffutils/diffutils_3.2.bb

index 74c371dc9eb3d04f6efe4168ace2d1d0b1be5b06..dc8719089ceebc9b188f1c9b40c502311cf07eaa 100644 (file)
@@ -3,6 +3,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
 
 require diffutils.inc
 
+do_configure_prepend () {
+       # Need to remove gettext macros with weird mix of versions
+       for i in codeset.m4 gettext_gl.m4 intlmacosx.m4 inttypes-pri.m4 lib-ld_gl.m4 lib-prefix_gl.m4 po_gl.m4 ssize_t.m4 wchar_t.m4 wint_t.m4; do
+               rm ${S}/m4/$i
+       done
+}
+
 PR = "${INC_PR}.0"
 
 SRC_URI += "file://remove-gets.patch"