]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-(wm/sato): moved creation of x-session-manager to matchbox-sato
authorMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 10:31:36 +0000 (10:31 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Wed, 9 Apr 2008 10:31:36 +0000 (10:31 +0000)
matchbox-sato contain session start scripts which are used as
x-session-manager so it should register it with update-alternatives
instead of matchbox-wm

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4214 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-sato/matchbox-sato_0.1.bb
meta/packages/matchbox-wm/matchbox-wm_1.2.bb
meta/packages/matchbox-wm/matchbox-wm_svn.bb

index e2f4aeb8256e162cfc541c70eb5bc473483c0c42..b8d6d7151ac08b19a0bc1db02cd043bbd8505b21 100644 (file)
@@ -3,11 +3,18 @@ LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato initscripts"
 RCONFLICTS = "matchbox-common"
-PR = "r20"
+PR = "r21"
 
 SRC_URI = "file://etc file://matchbox-session"
 S = ${WORKDIR}
 
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "x-session-manager"
+ALTERNATIVE_LINK = "${bindir}/x-session-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
 do_install() {
        install -d ${D}/${bindir}
        install -m 0755 ${S}/matchbox-session ${D}/${bindir}
index 745493522f635f46816d691e58059149b81a9fe6..f68eb2b4aec2ab21af3f857190bba836465095de 100644 (file)
@@ -2,7 +2,7 @@ SECTION = "x11/wm"
 DESCRIPTION = "Matchbox window manager"
 LICENSE = "GPL"
 DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes xdamage libxrender startup-notification expat"
-PR="r3"
+PR = "r4"
 
 SRC_URI = "http://matchbox-project.org/sources/matchbox-window-manager/1.2/matchbox-window-manager-${PV}.tar.bz2 \
            file://configure_fix.patch;patch=1 \
@@ -25,7 +25,12 @@ ALTERNATIVE_LINK = "${bindir}/x-session-manager"
 ALTERNATIVE_PATH = "${bindir}/matchbox-session"
 ALTERNATIVE_PRIORITY = "10"
 
-EXTRA_OECONF = " --enable-startup-notification --disable-xrm --with-expat-lib=${STAGING_LIBDIR} --with-expat-includes=${STAGING_INCDIR}"
+EXTRA_OECONF = " --enable-startup-notification \
+                 --disable-xrm \
+                 --enable-expat \
+                 --with-expat-lib=${STAGING_LIBDIR} \
+                 --with-expat-includes=${STAGING_INCDIR}"
+
 
 do_configure_prepend () {
         cp ${WORKDIR}/gconf-2.m4 ${S}/
index fc1e09e50300640e3f2928c9f739653959391167..d8a48e2ce6ad263eda69603c8de22e8f0d6ba7cd 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Matchbox window manager"
 LICENSE = "GPL"
 DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf"
 PV = "1.2+svnr${SRCREV}"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
            file://configure_fix.patch;patch=1;maxrev=1818 \
@@ -25,7 +25,11 @@ FILES_${PN} = "${bindir}/* \
                ${datadir}/themes/Default/matchbox \
                ${datadir}/themes/MBOpus/matchbox"
 
-EXTRA_OECONF = " --enable-startup-notification --disable-xrm --with-expat-lib=${STAGING_LIBDIR} --with-expat-includes=${STAGING_INCDIR} --enable-expat"
+EXTRA_OECONF = " --enable-startup-notification \
+                 --disable-xrm \
+                 --enable-expat \
+                 --with-expat-lib=${STAGING_LIBDIR} \
+                 --with-expat-includes=${STAGING_INCDIR}"
 
 do_install_prepend() {
        install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig