]> code.ossystems Code Review - openembedded-core.git/commitdiff
consolekit: remove /var/run from package
authorJonathan Liu <net147@gmail.com>
Sun, 26 May 2013 08:14:13 +0000 (18:14 +1000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 29 May 2013 21:07:24 +0000 (22:07 +0100)
The /var/run/ConsoleKit directory doesn't need to be included in the
package as it is created by console-kit-daemon if it doesn't exist.
The /var/run directory is already created by base-files.

Signed-off-by: Jonathan Liu <net147@gmail.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/consolekit/consolekit_0.4.5.bb

index db4ac0023717db75827327b9f969cbd9586255b6..7d66b390d4fff1f4065ad4b24420f5c4b45e4783 100644 (file)
@@ -37,3 +37,8 @@ FILES_${PN}-dbg += "${base_libdir}/security/.debug"
 PACKAGES =+ "pam-plugin-ck-connector"
 FILES_pam-plugin-ck-connector += "${base_libdir}/security/*.so"
 RDEPENDS_pam-plugin-ck-connector += "${PN}"
+
+do_install_append() {
+       # Remove /var/run from package as console-kit-daemon will populate it on startup
+       rm -fr "${D}${localstatedir}/run"
+}