]> code.ossystems Code Review - openembedded-core.git/commitdiff
apr: Remove workdir path references from installed apr files
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 12 Jan 2009 15:37:21 +0000 (15:37 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 12 Jan 2009 15:37:21 +0000 (15:37 +0000)
meta/packages/apr/apr-util_1.3.4.bb
meta/packages/apr/apr/configfix.patch [new file with mode: 0644]
meta/packages/apr/apr_1.3.3.bb

index 590c22e8820384ed6b73065115ce154e5ff2f9d9..2c9432a15755727338fda6b8b04ad1bde23625c4 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "libs"
 DEPENDS = "apr expat gdbm"
 LICENSE = "Apache License, Version 2.0"
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
            file://configure_fixes.patch;patch=1"
diff --git a/meta/packages/apr/apr/configfix.patch b/meta/packages/apr/apr/configfix.patch
new file mode 100644 (file)
index 0000000..ec46172
--- /dev/null
@@ -0,0 +1,51 @@
+Index: apr-1.3.3/apr-config.in
+===================================================================
+--- apr-1.3.3.orig/apr-config.in       2009-01-12 15:16:31.000000000 +0000
++++ apr-1.3.3/apr-config.in    2009-01-12 15:19:25.000000000 +0000
+@@ -152,14 +152,7 @@
+     flags="$flags $LDFLAGS"
+     ;;
+     --includes)
+-    if test "$location" = "installed"; then
+         flags="$flags -I$includedir $EXTRA_INCLUDES"
+-    elif test "$location" = "source"; then
+-        flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+-    else
+-        # this is for VPATH builds
+-        flags="$flags -I$APR_BUILD_DIR/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+-    fi
+     ;;
+     --srcdir)
+     echo $APR_SOURCE_DIR
+@@ -181,29 +167,14 @@
+     exit 0
+     ;;
+     --link-ld)
+-    if test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        flags="$flags -L$libdir -l${APR_LIBNAME}"
+-    else
+-        ### this surely can't work since the library is in .libs?
+-        flags="$flags -L$APR_BUILD_DIR -l${APR_LIBNAME}"
+-    fi
++        flags="$flags -l${APR_LIBNAME}"
+     ;;
+     --link-libtool)
+     # If the LA_FILE exists where we think it should be, use it.  If we're
+     # installed and the LA_FILE does not exist, assume to use -L/-l
+     # (the LA_FILE may not have been installed).  If we're building ourselves,
+     # we'll assume that at some point the .la file be created.
+-    if test -f "$LA_FILE"; then
+-        flags="$flags $LA_FILE"
+-    elif test "$location" = "installed"; then
+-        ### avoid using -L if libdir is a "standard" location like /usr/lib
+-        # Since the user is specifying they are linking with libtool, we
+-        # *know* that -R will be recognized by libtool.
+-        flags="$flags -L$libdir -R$libdir -l${APR_LIBNAME}"
+-    else
+-        flags="$flags $LA_FILE"
+-    fi
++        flags="$flags ll${APR_LIBNAME}"
+     ;;
+     --shlib-path-var)
+     echo "$SHLIBPATH_VAR"
index 3e23bcd878badf037b5a442fdc4bb31ba51a6434..ac25246bee2a9fff51ff5dfb6d8760828a6db500 100644 (file)
@@ -2,10 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
 SECTION = "libs"
 LICENSE = "Apache License, Version 2.0"
 
-PR = "r0"
+PR = "r2"
 
 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
-           file://configure_fixes.patch;patch=1"
+           file://configure_fixes.patch;patch=1 \
+           file://configfix.patch;patch=1"
 
 inherit autotools lib_package binconfig