]> code.ossystems Code Review - openembedded-core.git/commitdiff
sysklogd: refresh patches
authorRoss Burton <ross.burton@intel.com>
Wed, 15 Nov 2017 16:45:52 +0000 (16:45 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 7 Mar 2018 14:33:57 +0000 (06:33 -0800)
The patch tool will apply patches by default with "fuzz", which is where if the
hunk context isn't present but what is there is close enough, it will force the
patch in.

Whilst this is useful when there's just whitespace changes, when applied to
source it is possible for a patch applied with fuzz to produce broken code which
still compiles (see #10450).  This is obviously bad.

We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For
that to be realistic the existing patches with fuzz need to be rebased and
reviewed.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/sysklogd/files/no-strip-install.patch

index 00fba71017e978d183427bedb4a2b0f98f0a8a64..d426c83bf25bbe9b5694746d4ac49a0db97ed5ab 100644 (file)
@@ -1,10 +1,10 @@
 Upstream-Status: Inappropriate [configuration]
 
-Index: sysklogd-1.5/Makefile
+Index: sysklogd-1.5.1/Makefile
 ===================================================================
---- sysklogd-1.5.orig/Makefile 2009-06-09 13:02:41.000000000 +0200
-+++ sysklogd-1.5/Makefile      2009-06-09 13:03:06.000000000 +0200
-@@ -127,8 +127,8 @@
+--- sysklogd-1.5.1.orig/Makefile
++++ sysklogd-1.5.1/Makefile
+@@ -127,8 +127,8 @@ clobber: clean
        rm -f syslogd klogd ksym syslog_tst oops_test TAGS tsyslogd tklogd
  
  install_exec: syslogd klogd
@@ -14,4 +14,4 @@ Index: sysklogd-1.5/Makefile
 +      ${INSTALL} -m 500 klogd ${BINDIR}/klogd
  
  install_man:
-       ${INSTALL} -m ${MAN_PERMS} sysklogd.8 ${MANDIR}/man8/sysklogd.8
+       ${INSTALL} -o ${MAN_USER} -g ${MAN_GROUP} -m ${MAN_PERMS} sysklogd.8 ${MANDIR}/man8/sysklogd.8