]> code.ossystems Code Review - openembedded-core.git/commitdiff
elfutils: remove i386_dis.h/x86_64_dis.h compilation targets
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Thu, 28 Mar 2013 13:51:58 +0000 (15:51 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 29 Mar 2013 10:40:18 +0000 (10:40 +0000)
Since we provide those files manually (i386_gendis, which is needed for
generating those files, has to be run on host and would fail when
compiling for other architectures), the mentioned compilation targets
in libcpu/ are not needed anymore.

This change will avoid a nasty race condition when running "make -jX
install" resulting in a zero size libebl_i386.so file. The issue happens
because, at "make install" time, the *_dis.h prerequisites will be newer
than the target itself, triggering a chain of recompilations while, in
the same time, the binary files are copied to the destination directory.
Hence, the zero sized file...

[YOCTO #4131]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/elfutils/elfutils_0.148.bb

index e8d58fbde5135062081464da876740cd238d869c..9c0a08eafad995e2efa434ea58738781c0fbbbeb 100644 (file)
@@ -52,7 +52,7 @@ EXTRA_OECONF_append_class-native = " --without-bzlib"
 EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
 
 do_configure_prepend() {
-       sed -i 's:./i386_gendis:echo\ \#:g' ${S}/libcpu/Makefile.am
+       sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
 
        cp ${WORKDIR}/*dis.h ${S}/libcpu
 }