]> code.ossystems Code Review - openembedded-core.git/commitdiff
gnu-config: Use perl from the environment, not a hardcoded path
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2011 11:44:11 +0000 (11:44 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 17 Mar 2011 11:49:47 +0000 (11:49 +0000)
Using the hardcoded perl binary can cause conflict between the files in the native
sysroot and those of the build system perl. By using perl from the environment
we can at least ensure a consistent perl environment.

Patches taken from OE.dev commits:
be21179c5321bd0afb9221f020ac12ad75c86a3b gnu-config: use /usr/bin/env perl instead of /usr/bin/perl in gnu-configize.in
edcdefbf6e0675c1bcc1fc4f464f654223380e50 gnu-config: update also bindir change to replace /usr/bin/env instead of /usr/bin/perl

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gnu-config/gnu-config/gnu-configize.in
meta/recipes-devtools/gnu-config/gnu-config_20080123.bb

index be8580c8e618be71073dfeba1a648be6da57d77e..d4908fc4f9d7f08d4aa116e1d0ef400f1f52ad2d 100755 (executable)
@@ -1,4 +1,4 @@
-#! /usr/bin/perl -w
+#! /usr/bin/env perl
 # -*- perl -*-
 
 eval 'case $# in 0) exec /usr/bin/perl -S "$0";; *) exec /usr/bin/perl -S "$0" "$@";; esac'
index 2629ecb52fd6214904d46258baabdcf9f9af6339..e0a815560ffdc45a1721badacfff3c0e11b89c93 100644 (file)
@@ -8,7 +8,7 @@ INHIBIT_DEFAULT_DEPS = "1"
 
 FIXEDSRCDATE = "${@bb.data.getVar('FILE', d, 1).split('_')[-1].split('.')[0]}"
 PV = "0.1+cvs${FIXEDSRCDATE}"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "cvs://anonymous@cvs.sv.gnu.org/cvsroot/config;module=config;method=pserver;date=${FIXEDSRCDATE} \
           file://config-guess-uclibc.patch \
@@ -27,7 +27,7 @@ do_install () {
                    -e 's,@autom4te_perllibdir@,${datadir}/autoconf,g' > ${D}${bindir}/gnu-configize
        # In the native case we want the system perl as perl-native can't have built yet
        if [ "${BUILD_ARCH}" != "${TARGET_ARCH}" ]; then
-               sed -i -e 's,/usr/bin/perl,${bindir}/perl,g' ${D}${bindir}/gnu-configize
+               sed -i -e 's,/usr/bin/env,${bindir}/env,g' ${D}${bindir}/gnu-configize
        fi
        chmod 755 ${D}${bindir}/gnu-configize
        install -m 0644 config.guess config.sub ${D}${datadir}/gnu-config/