]> code.ossystems Code Review - openembedded-core.git/commitdiff
cracklib: disable building the python module
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 9 May 2016 14:17:13 +0000 (17:17 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 1 Jun 2016 07:04:11 +0000 (08:04 +0100)
It's tricky to convert to Python 3 and isn't required by anything in
oe-core or meta-oe.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
meta/recipes-extended/cracklib/cracklib_2.9.5.bb

index 3bd3f93674e0c3ba78f6a7d46c92e5b2250d23cb..c185d23efd5650dd22be14f25a2ad4e0424a78c9 100644 (file)
@@ -4,12 +4,9 @@ HOMEPAGE = "http://sourceforge.net/projects/cracklib"
 LICENSE = "LGPLv2.1+"
 LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06"
 
-DEPENDS = "cracklib-native zlib python"
-RDEPEND_${PN}-python += "python"
+DEPENDS = "cracklib-native zlib"
 
-PACKAGES += "${PN}-python"
-
-EXTRA_OECONF = "--with-python --libdir=${base_libdir}"
+EXTRA_OECONF = "--without-python --libdir=${base_libdir}"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/cracklib/cracklib-${PV}.tar.gz \
            file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \
@@ -21,27 +18,11 @@ SRC_URI[sha256sum] = "59ab0138bc8cf90cccb8509b6969a024d5e58d2d02bcbdccbb9ba9b88b
 UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/cracklib/files/cracklib/"
 UPSTREAM_CHECK_REGEX = "/cracklib/(?P<pver>(\d+[\.\-_]*)+)/"
 
-inherit autotools gettext pythonnative python-dir
+inherit autotools gettext
 
 do_install_append_class-target() {
        create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small
 }
 
-do_install_append() {
-       src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages"
-       rm -f $src_dir/test_cracklib.py*
-
-       if [ "${base_libdir}" != "${libdir}" ] ; then
-          # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir}
-          install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/
-          mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR}
-          rm -fr ${D}${base_libdir}/${PYTHON_DIR}
-       fi
-}
-
 BBCLASSEXTEND = "native nativesdk"
 
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/cracklib.py* \
-       ${PYTHON_SITEPACKAGES_DIR}/_cracklib.*"
-
-FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_cracklib.a"