]> code.ossystems Code Review - openembedded-core.git/commitdiff
opensp: Fix hard path in native nsgmls.
authorZhai Edwin <edwin.zhai@intel.com>
Tue, 13 Sep 2011 16:02:51 +0000 (17:02 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Sep 2011 16:03:54 +0000 (17:03 +0100)
This relocation issues caused following bug and introduce one partial fix bb024d:
[YOCTO #1440]

But the environment val hacking is not working all the time, as nsgmsl may
append wrong path in some case. This fix use search directory "-D" as solution.
And more important, change the iputils' way to make doc: Use the sysid in
current directory instead of parent directory, as "../" is also appended to the
search directory then lead searching failure.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
CC: Saul Would <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opensp/opensp_1.5.bb
meta/recipes-extended/iputils/files/nsgmls-path-fix.patch [new file with mode: 0644]
meta/recipes-extended/iputils/iputils_s20101006.bb

index a402d11c726de3b28865297587548b8a7469eb43..d69213745246d995be54478819a11188824af77b 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
 
-PR = "r1"
+PR = "r2"
 
 # At -Os it encounters calls to some inline functions which are then
 # not found in any other objects with gcc 4.5
@@ -42,6 +42,13 @@ do_install_append() {
        ln -sf osx sgml2xml
 }
 
+do_install_append_virtclass-native() {
+       for util in nsgmls sgmlnorm spam spcat spent sx; do
+               create_cmdline_wrapper ${D}/${bindir}/$util \
+                   -D ${sysconfdir}/sgml
+       done
+}
+
 FILES_${PN} += "${datadir}/OpenSP/"
 
 BBCLASSEXTEND = "native"
diff --git a/meta/recipes-extended/iputils/files/nsgmls-path-fix.patch b/meta/recipes-extended/iputils/files/nsgmls-path-fix.patch
new file mode 100644 (file)
index 0000000..92bf946
--- /dev/null
@@ -0,0 +1,27 @@
+Fix nsgmls path issue
+
+Upstream-Status: Pending
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+Index: iputils-s20101006/doc/Makefile
+===================================================================
+--- iputils-s20101006.orig/doc/Makefile        2011-09-13 20:42:27.000000000 +0800
++++ iputils-s20101006/doc/Makefile     2011-09-13 21:01:52.000000000 +0800
+@@ -27,10 +27,15 @@
+ # docbook2man produces utterly ugly output and I did not find
+ # any way to customize this but hacking backend perl script a little.
+ # Well, hence...
++# nsgmls seems append path to search directory according to the sysid path.
++# e.g. if input ../index.db, it would search $search_directory/../ rather than
++# $search_directory, which leads searching failure. Fixing nsgmls probably
++# introduce some side effects, so use this ugly hack: running nsgmls in current
++# directory, and running docbook2man in tmp directory.
+ $(MANFILES): index.db
+       @-mkdir tmp.db2man
+-      @set -e; cd tmp.db2man; nsgmls ../$< | sgmlspl ../docbook2man-spec.pl ; mv $@ ..
++      @set -e; nsgmls $< >tmp.db2man/output; cd tmp.db2man; cat output | sgmlspl ../docbook2man-spec.pl ;     mv $@ ..
+       @-rm -rf tmp.db2man
+ clean:
index c97fce71be47bd04ad6506e8ef6d440e3bfd1156..5216c10821e18a779f90a6718cf6d382537bbf72 100644 (file)
@@ -21,6 +21,7 @@ SRC_URI = "http://www.skbuff.net/iputils/${BPN}-${PV}.tar.bz2 \
            file://debian/use_gethostbyname2.diff \
            file://debian/targets.diff \
            file://debian/fix-arping-timeouts.diff \
+           file://nsgmls-path-fix.patch \
           "
 
 SRC_URI[md5sum] = "a36c25e9ec17e48be514dc0485e7376c"