]> code.ossystems Code Review - openembedded-core.git/commitdiff
portmap: obey 'tcp-wrappers' PACKAGECONFIG
authorChristopher Larson <chris_larson@mentor.com>
Fri, 31 May 2013 02:26:28 +0000 (19:26 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 31 May 2013 07:02:43 +0000 (08:02 +0100)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/portmap/portmap_6.0.bb

index 07aa3601fa29c51b8a307a80535f822f18fb0b29..2ec698155972dd33d0799c08a59fef5d5bc55fb6 100644 (file)
@@ -1,6 +1,5 @@
 require portmap.inc
 
-DEPENDS += "tcp-wrappers"
 PR = "r7"
 
 SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
@@ -13,8 +12,12 @@ SRC_URI[sha256sum] = "02c820d39f3e6e729d1bea3287a2d8a6c684f1006fb9612f97dcad4a28
 
 S = "${WORKDIR}/${BPN}_${PV}/"
 
+PACKAGECONFIG ??= "tcp-wrappers"
+PACKAGECONFIG[tcp-wrappers] = ",,tcp-wrappers"
+
 CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS -DHOSTS_ACCESS"
 CFLAGS += "-Wall -Wstrict-prototypes -fPIC"
+EXTRA_OEMAKE += "'NO_TCP_WRAPPER=${@base_contains('PACKAGECONFIG', 'tcp-wrappers', '', '1', d)}'"
 
 fakeroot do_install() {
     install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d