]> code.ossystems Code Review - openembedded-core.git/commitdiff
mesa: upgrade to 9.2.5
authorValentin Popa <valentin.popa@intel.com>
Tue, 18 Feb 2014 11:32:16 +0000 (13:32 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Feb 2014 14:28:03 +0000 (14:28 +0000)
tested on qemux86, genericx86 for core-image-sato
and core-image-weston.

Signed-off-by: Valentin Popa <valentin.popa@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-graphics/mesa/mesa-gl_9.2.5.bb [moved from meta/recipes-graphics/mesa/mesa-gl_9.2.2.bb with 100% similarity]
meta/recipes-graphics/mesa/mesa_9.2.2.bb [deleted file]
meta/recipes-graphics/mesa/mesa_9.2.5.bb [new file with mode: 0644]
meta/recipes-graphics/mesa/mesa_git.bb

diff --git a/meta/recipes-graphics/mesa/mesa_9.2.2.bb b/meta/recipes-graphics/mesa/mesa_9.2.2.bb
deleted file mode 100644 (file)
index 60eba01..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-require ${BPN}.inc
-
-SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
-           file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
-           file://0006-fix-out-of-tree-egl.patch \
-           "
-
-SRC_URI[md5sum] = "20887f8020db7d1736a01ae9cd5d8c38"
-SRC_URI[sha256sum] = "c78a5035233672844cf2492fe82dc10877e12026be227d04469d6ca6ac656a3d"
-
-S = "${WORKDIR}/Mesa-${PV}"
diff --git a/meta/recipes-graphics/mesa/mesa_9.2.5.bb b/meta/recipes-graphics/mesa/mesa_9.2.5.bb
new file mode 100644 (file)
index 0000000..737ed1a
--- /dev/null
@@ -0,0 +1,19 @@
+require ${BPN}.inc
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+           file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
+           file://0006-fix-out-of-tree-egl.patch \
+           "
+
+SRC_URI[md5sum] = "9fb4de29ca1d9cfd03cbdefa123ba336"
+SRC_URI[sha256sum] = "b46ab9efed176df0591993397594d712ada9da6a47fd31bbe75050fe28eb6bf0"
+
+S = "${WORKDIR}/Mesa-${PV}"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+    if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+        sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+    fi
+}
index 19d3e70823fe689acb020fe48af5945129f275fc..0abedbcb83c50e84b5f534d6548cb4f19d24fb7d 100644 (file)
@@ -5,8 +5,8 @@ DEFAULT_PREFERENCE = "-1"
 LIC_FILES_CHKSUM = "file://docs/license.html;md5=f69a4626e9efc40fa0d3cc3b02c9eacf"
 
 PR = "${INC_PR}.0"
-SRCREV = "8f0742051e8501e737affb392996aef172034ca8"
-PV = "9.2.2+git${SRCPV}"
+SRCREV = "4636e87191fddd492ed8c61ba61faf4b2d89b2e4"
+PV = "9.2.5+git${SRCPV}"
 
 SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa \
            file://0002-pipe_loader_sw-include-xlib_sw_winsys.h-only-when-HA.patch \
@@ -14,3 +14,11 @@ SRC_URI = "git://anongit.freedesktop.org/git/mesa/mesa \
            "
 
 S = "${WORKDIR}/git"
+
+#because we cannot rely on the fact that all apps will use pkgconfig,
+#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
+do_install_append() {
+    if ${@base_contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
+        sed -i -e 's/^#ifdef MESA_EGL_NO_X11_HEADERS/#if ${@base_contains('DISTRO_FEATURES', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+    fi
+}