]> code.ossystems Code Review - openembedded-core.git/commitdiff
libgalago_0.5.2.bb: Fix compile for uclibc
authorKhem Raj <raj.khem@gmail.com>
Fri, 6 May 2011 05:10:22 +0000 (22:10 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 10 May 2011 08:51:40 +0000 (09:51 +0100)
uclibc targets may not have gettext but this package
still needs config.rpath during regenerating configury
so we provide it when libc is uclibc.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-connectivity/galago/libgalago_0.5.2.bb

index 6d9f76b8600af87e7579a0fbcd594e18cc88ec8f..3a476209af0bc49d5de8044abef42f3770e3ed18 100644 (file)
@@ -18,3 +18,7 @@ PR = "r2"
 inherit autotools pkgconfig gettext
 
 EXTRA_OECONF = "--disable-tests --disable-check"
+
+do_configure_prepend_libc-uclibc() {
+        touch ${S}/config.rpath
+}