]> code.ossystems Code Review - openembedded-core.git/commitdiff
Introduce new SERIAL_CONSOLES to add multiple consoles for your MACHINE
authorMatthew McClintock <msm@freescale.com>
Fri, 4 Nov 2011 21:07:52 +0000 (16:07 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Nov 2011 11:35:31 +0000 (11:35 +0000)
Just define additional serial consoles like so:

SERIAL_CONSOLES="115200;ttyS0 115200;ttyS1 ... 115200;ttySN"

Also be sure to remove SERIAL_CONSOLE (lacking the S) from your
machine as they can conflict.

Signed-off-by: Matthew McClintock <msm@freescale.com>
meta/recipes-core/sysvinit/sysvinit-inittab_2.88dsf.bb

index ba60c74412e7ed1738cf7e1c0b2effc76ca3cb6a..3a716d7d7a114a6c1a62fb7495ff440e1cb05230 100644 (file)
@@ -25,6 +25,16 @@ do_install() {
     if [ ! -z "${SERIAL_CONSOLE}" ]; then
         echo "S:2345:respawn:${base_sbindir}/getty ${SERIAL_CONSOLE}" >> ${D}${sysconfdir}/inittab
     fi
+
+    idx=0
+    tmp="${SERIAL_CONSOLES}"
+    for i in $tmp
+    do
+       j=`echo ${i} | sed s/\;/\ /g`
+        echo "${idx}:2345:respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
+       idx=`expr $idx + 1`
+    done
+
     if [ "${USE_VT}" = "1" ]; then
         cat <<EOF >>${D}${sysconfdir}/inittab
 # ${base_sbindir}/getty invocations for the runlevels.