]> code.ossystems Code Review - openembedded-core.git/commitdiff
wpebackend-fdo: Fix missing .so symlink when using dev package
authorZbigniew Bodek <zbigniew.bodek@huawei.com>
Fri, 19 Feb 2021 17:19:54 +0000 (02:19 +0900)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Mar 2021 00:24:18 +0000 (00:24 +0000)
Problem spotted on dunfell-23.0.4

Normally, unversioned .so is removed from -dev (default) package
however it is still being referred by other agents, such as webkitgtk.
That can be observed while executing i.e. Epiphany Browser.

For instance:
platformInitializeWebProcess()
calls
wpe_loader_init("libWPEBackend-fdo-1.0.so")

as a result one can see:
--------------------
wpe_loader_init could not load the library 'libWPEBackend-fdo-1.0.so':
libWPEBackend-fdo-1.0.so: cannot open shared object file:
No such file or directory
--------------------

"master" branch contains a bumped-up version of webkitgtk
to which this issue does not apply (the code has changed).

Forcefully keep this .so symlink to resolve the problem in dunfell.

Signed-off-by: Zbigniew Bodek <zbigniew.bodek@huawei.com>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-sato/webkit/wpebackend-fdo_1.7.1.bb

index 519762d1257929abce320e98d7eba03cad0ec3f6..15f4f4276cf65cee34048de130b001fea2fbaa75 100644 (file)
@@ -15,3 +15,6 @@ REQUIRED_DISTRO_FEATURES = "opengl"
 SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
 SRC_URI[sha256sum] = "9b980a73ea4e3762266c48f81ded56d9dcad4acf32bad9bd05d0dffdd454c6f5"
 
+FILES_${PN} += "${libdir}/libWPEBackend-fdo-1.0.so"
+FILES_SOLIBSDEV = ""
+INSANE_SKIP_${PN} += "dev-so"