]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-numpy: Avoid installing copy of f2py script
authorAlejandro Enedino Hernandez Samaniego <alejandro.enedino.hernandez-samaniego@xilinx.com>
Fri, 17 May 2019 23:49:12 +0000 (16:49 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 21 May 2019 11:56:16 +0000 (12:56 +0100)
Both python-numpy and python3-numpy try to install the file:

${D}/${bindir}/f2py

which causes an error during do_rootfs since the package manager complains about that.

The numpy packages create basically copies of f2py script with the following names:
f2py (on both)
f2py2 (on python 2)
f2py2.7 (on python 2)
f2py3 (on python 3)
f2py3.7 (on python 3)

Remove the copy of f2py from python-numpy in favor of using the one from python3
to avoid installation issues at do_rootfs().

Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandr@xilinx.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python-numpy/python-numpy_1.16.3.bb

index 50137895ca1503ff9ef9cf01e7e57bb072d97ed1..a1133dad41ca05bd6fac934bd7cc0201b6b8dae0 100644 (file)
@@ -4,3 +4,7 @@ require python-numpy.inc
 RDEPENDS_${PN}_class-target_append = " \
     ${PYTHON_PN}-subprocess \
 "
+
+do_install_append(){
+        rm ${D}/${bindir}/f2py
+}