]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel-devsrc: 5.8 + gcc10 require gcc-plugins + libmpc-dev
authorBruce Ashfield <bruce.ashfield@gmail.com>
Wed, 12 Aug 2020 17:03:31 +0000 (13:03 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Aug 2020 07:03:32 +0000 (08:03 +0100)
In order to execute 'make scripts prepare' on target with the
5.8 kernel and gcc 10, we need to have the gcc-plugins and
libmpc-dev on target.

Although not strictly required for all kernel versions, they
don't do any harm when included.

We add them to the RDEPENDS of devsrc to avoid the errors:

   scripts/gcc-plugins/gcc-common.h:5:10: fatal error: bversion.h: No such
   file or directory
   | #include "bversion.h"

and

   /usr/lib/gcc/arm-poky-linux-gnueabi/10.1.0/plugin/include/builtins.h:23:10:
     fatal error: mpc.h: No such file or directory

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/kernel-devsrc.bb

index 34b947b5999bc02735bf86bc676217ad73d120e3..a9c7be0f819288c84f97dc49f2d950668c15acf9 100644 (file)
@@ -290,3 +290,5 @@ RDEPENDS_${PN} = "bc python3 flex bison ${TCLIBC}-utils"
 RDEPENDS_${PN} += "openssl-dev util-linux"
 # and x86 needs a bit more for 4.15+
 RDEPENDS_${PN} += "${@bb.utils.contains('ARCH', 'x86', 'elfutils', '', d)}"
+# 5.8+ needs gcc-plugins libmpc-dev
+RDEPENDS_${PN} += "gcc-plugins libmpc-dev"