]> code.ossystems Code Review - openembedded-core.git/commitdiff
matchbox-stroke: : fix build issue with gcc dso linking change
authorNitin A Kamble <nitin.a.kamble@intel.com>
Tue, 11 Jan 2011 17:48:49 +0000 (09:48 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 20 Jan 2011 21:37:04 +0000 (21:37 +0000)
All the libraries needs to be specified explicitely with the new gcc dso
linking change patch. This was causing build errors for this
recipe. Specifying the libxrender library explicitely for
linking to work without errors.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-sato/matchbox-stroke/files/dso_linking_change_build_fix.patch [new file with mode: 0644]
meta/recipes-sato/matchbox-stroke/matchbox-stroke_svn.bb

diff --git a/meta/recipes-sato/matchbox-stroke/files/dso_linking_change_build_fix.patch b/meta/recipes-sato/matchbox-stroke/files/dso_linking_change_build_fix.patch
new file mode 100644 (file)
index 0000000..dd45341
--- /dev/null
@@ -0,0 +1,36 @@
+after gcc linking has changed, all the libraries must be explicitely specified 
+This patch avoids these linking errors:
+
+| make[1]: Entering directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/matchbox-stroke-0.0+svnr1820-r0/matchbox-stroke'^M
+| Making all in src^M
+| make[2]: Entering directory `/disk0/pokybuild/build1/tmp/work/i586-poky-linux/matchbox-stroke-0.0+svnr1820-r0/matchbox-stroke/src'^M
+| ccache i586-poky-linux-gcc -march=i586 --sysroot=/disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux  -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types  -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -o matchbox-stroke matchbox-stroke.o matchbox-stroke-ui.o matchbox-stroke-recog.o matchbox-stroke-mode.o matchbox-stroke-action.o config-parser.o util-hash.o util.o -lXft -lX11 -lXtst -lfakekey   -lexpat -lm^M
+| /disk0/pokybuild/build1/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: u: invalid DSO for symbol `XRenderFindVisualFormat' definition^M
+| /disk0/pokybuild/build1/tmp/sysroots/i586-poky-linux/usr/lib/libXrender.so.1: could not read symbols: Bad value^M
+| collect2: ld returned 1 exit status^M
+| make[2]: *** [matchbox-stroke] Error 1
+
+Nitin A Kamble <nitin.a.kamble@intel.com>
+Date: 2011/01/11
+
+
+Index: matchbox-stroke/configure.ac
+===================================================================
+--- matchbox-stroke.orig/configure.ac
++++ matchbox-stroke/configure.ac
+@@ -38,7 +38,7 @@ AC_ARG_WITH(expat-lib,         
+          expat_lib=$withval, expat_lib=yes)
+-PKG_CHECK_MODULES(MBSTROKE, xft libfakekey,,
++PKG_CHECK_MODULES(MBSTROKE, xft libfakekey xrender,,
+                AC_MSG_ERROR([*** Required Librarys not found ***]))
+ dnl ------ Expat ------------------------------------------------------------
+@@ -160,4 +160,4 @@ echo "
+         compiler:               ${CC} 
+         Building with Debug:    ${enable_debug}
+-"
+\ No newline at end of file
++"
index 5021d8839ec2736769f1056ff63cf4126c739bdf..de675c2b9b5c480099c0259968cbb53deabc1ce1 100644 (file)
@@ -8,10 +8,12 @@ LIC_FILES_CHKSUM = "file://src/matchbox-stroke.h;endline=12;md5=8ed5c5bbec2321fb
 DEPENDS = "libfakekey expat libxft"
 SECTION = "x11/wm"
 PV = "0.0+svnr${SRCPV}"
+PR = "r1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
            file://single-instance.patch;patch=1 \
-           file://configure_fix.patch;patch=1;maxrev=1819 "
+           file://configure_fix.patch;patch=1;maxrev=1819 \
+           file://dso_linking_change_build_fix.patch "
 
 S = "${WORKDIR}/${PN}"