]> code.ossystems Code Review - openembedded-core.git/commitdiff
Perl packages shouldn't be allarch
authorJesse Zhang <sen.zhang@windriver.com>
Tue, 19 Mar 2013 02:07:01 +0000 (10:07 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 23 Mar 2013 11:51:22 +0000 (11:51 +0000)
Perl packages should know about arch so that they could install to the
correct libdir. Or else they always install to the default libdir in
multilib builds.

Signed-off-by: Jesse Zhang <sen.zhang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/perl/libconvert-asn1-perl_0.26.bb
meta/recipes-extended/perl/libtimedate-perl_2.30.bb
meta/recipes-extended/perl/libxml-namespacesupport-perl_1.11.bb
meta/recipes-extended/perl/libxml-sax-base-perl_1.08.bb
meta/recipes-extended/perl/libxml-sax-perl_0.99.bb

index f6937ec78f70ecf79b6495af910975d397bfdf6a..cd3141a91b3a05efd67babc76abb57ea02c9bccb 100644 (file)
@@ -11,7 +11,7 @@ SRC_URI[sha256sum] = "5db8b62fa0d036bd0cabc869ffe17941ad587d9a2af1ff030d554872ad
 
 S = "${WORKDIR}/Convert-ASN1-${PV}"
 
-inherit cpan allarch
+inherit cpan
 
 EXTRA_PERLFLAGS = "-I ${STAGING_LIBDIR_NATIVE}/perl-native/perl/${@get_perl_version(d)}"
 
index e2aa86baa164d8d4535503050455191dfca37b66..80595afbef8a87f4c3d51487e3d52a96aab8b215 100644 (file)
@@ -9,7 +9,7 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${PV}.tar.
 
 S = "${WORKDIR}/TimeDate-${PV}"
 
-inherit cpan allarch
+inherit cpan
 
 BBCLASSEXTEND = "native"
 
index 928440377cece39d6b08c9bdef6e51ae3c5e3d9a..9a9e71011e4591f3d3d9648690529e91b382ae56 100644 (file)
@@ -16,7 +16,7 @@ SRC_URI[sha256sum] = "6d8151f0a3f102313d76b64bfd1c2d9ed46bfe63a16f038e7d860fda28
 
 S = "${WORKDIR}/XML-NamespaceSupport-${PV}"
 
-inherit cpan allarch
+inherit cpan
 
 BBCLASSEXTEND="native"
 
index d7389a094c2b7aca8e6603aa8098ec68e1fdb2aa..3242f7b7edd40f50a1d06b95966f60bccc4e27d6 100644 (file)
@@ -19,6 +19,6 @@ SRC_URI[sha256sum] = "666270318b15f88b8427e585198abbc19bc2e6ccb36dc4c0a4f2d98073
 
 S = "${WORKDIR}/XML-SAX-Base-${PV}"
 
-inherit cpan allarch
+inherit cpan
 
 BBCLASSEXTEND = "native"
index 647cb77fa844ebd23b063956a519ad774fcf6d75..e2e0341f41fa7a51ab35109bc444b06af6ccf954 100644 (file)
@@ -22,6 +22,6 @@ SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6
 
 S = "${WORKDIR}/XML-SAX-${PV}"
 
-inherit cpan allarch
+inherit cpan
 
 BBCLASSEXTEND = "native"