]> code.ossystems Code Review - openembedded-core.git/commitdiff
dosfstools: fix CP437 error from `dosfsck -l`
authorChristopher Larson <chris_larson@mentor.com>
Tue, 26 Nov 2019 18:08:28 +0000 (23:08 +0500)
committerAnuj Mittal <anuj.mittal@intel.com>
Fri, 6 Dec 2019 05:14:48 +0000 (13:14 +0800)
Fix this error seen when using dosfsck -l to list fs contents:

    CP437: Invalid argument

(From OE-Core rev: 8a5fdac3c2d207b2cfac64ec2a2626c3ef154d84)

Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
meta/recipes-devtools/dosfstools/dosfstools_4.1.bb

index 69aa81af44f7a3359945e47078b18ab4a73c575e..23b88366705098c272c20875157d740163ff0c4a 100644 (file)
@@ -23,3 +23,6 @@ EXTRA_OECONF = "--without-udev --enable-compat-symlinks"
 CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
 
 BBCLASSEXTEND = "native"
+
+# Add codepage437 to avoid error from `dosfsck -l`
+RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"