]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-keyrings: do not use 'exit 1' to postpone to first boot
authorHongxu Jia <hongxu.jia@windriver.com>
Wed, 5 Sep 2018 12:36:02 +0000 (08:36 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Sep 2018 09:36:25 +0000 (10:36 +0100)
Since `229f4e9 package.bbclass: add support for
pkg_postinst_ontarget()' applied in oe-core, use
pkg_postinst_ontarget to run postinst at first boot.

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb

index 18d6abdded199705aec73df496c344bc62466e84..a20e316a3d1e8b67b08a5647149efe28ce75f013 100644 (file)
@@ -35,14 +35,6 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
 # We need 'opkg-key' to run the postinst script
 RDEPENDS_${PN} = "opkg"
 
-pkg_postinst_${PN} () {
-#! /bin/sh
-set -e
-
-if [ x"$D" = "x" ]; then
-    # On target
-    opkg-key populate
-else
-    exit 1
-fi
+pkg_postinst_ontarget_${PN} () {
+opkg-key populate
 }