]> code.ossystems Code Review - openembedded-core.git/commitdiff
yum-native: Add extract-postinst.awk script for use during rootfs generation
authorRichard Purdie <richard@openedhand.com>
Wed, 3 Sep 2008 23:20:58 +0000 (23:20 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 3 Sep 2008 23:20:58 +0000 (23:20 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@5133 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/yum/yum-native/extract-postinst.awk [new file with mode: 0644]
meta/packages/yum/yum-native_3.2.18.bb

diff --git a/meta/packages/yum/yum-native/extract-postinst.awk b/meta/packages/yum/yum-native/extract-postinst.awk
new file mode 100644 (file)
index 0000000..8f2836b
--- /dev/null
@@ -0,0 +1,11 @@
+/Name:.*/ {
+  package = substr($0, 7)
+  next
+}
+/postinstall.*scriptlet .*/ {
+  next
+}
+{
+  print $0 >> ENVIRON["D"] "/etc/rpm-postinsts/" package ".sh"
+}
+    
index d90f158cd67d17ad46f00527b71e04351bf4406d..76e92b34a9b6ad334f29e0da393b9ff8ccc6ec50 100644 (file)
@@ -2,7 +2,8 @@ HOMEPAGE = "http://linux.duke.edu/projects/yum/"
 
 SRC_URI = "http://linux.duke.edu/projects/yum/download/3.2/yum-${PV}.tar.gz \
            file://hacks.patch;patch=1 \
-           file://paths.patch;patch=1"
+           file://paths.patch;patch=1 \
+          file://extract-postinst.awk"
 PR = "r4"
 
 DEPENDS = "rpm-native python-native python-iniparse-native python-urlgrabber-native yum-metadata-parser-native libxml2-native"
@@ -15,3 +16,8 @@ do_compile_append () {
        sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum.py
        sed -e 's#!/usr/bin/python#!${bindir}/python#' -e 's#/usr/share#${datadir}#' -i ${S}/bin/yum-updatesd.py
 }
+
+do_install_append () {
+       install -d ${STAGING_BINDIR}/
+       install ${WORKDIR}/extract-postinst.awk ${STAGING_BINDIR}/
+}