]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd: fix immediate unmount of mountpoints not in fstab
authorJoshua Lock <joshua.lock@collabora.co.uk>
Wed, 8 Jul 2015 09:35:55 +0000 (10:35 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 8 Jul 2015 12:11:01 +0000 (13:11 +0100)
Systemd 219 immediately unmounts any mounts which don't exist
in fstab. See FDo bug #89383:
https://bugs.freedesktop.org/show_bug.cgi?id=89383

Patch from Fedora:
http://pkgs.fedoraproject.org/cgit/systemd.git/commit/?h=f22&id=9bbe0e92dc59d5a42258c729b105a7d9901eb35e

Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd/0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch [new file with mode: 0644]
meta/recipes-core/systemd/systemd_219.bb

diff --git a/meta/recipes-core/systemd/systemd/0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch b/meta/recipes-core/systemd/systemd/0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
new file mode 100644 (file)
index 0000000..d69cfe0
--- /dev/null
@@ -0,0 +1,36 @@
+From eb7a760052667c5a35637901de9359c377263804 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Tue, 24 Feb 2015 10:12:28 -0500
+Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
+ mounts too"
+
+This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
+
+This patch was imported from Fedora (http://pkgs.fedoraproject.org/cgit/systemd.git/commit/?h=f22&id=9bbe0e92dc59d5a42258c729b105a7d9901eb35e).
+
+It fixes an issue where mount points not listed in fstab are immediately
+unmounted after a call to mount.
+
+Upstream-Status: Inappropriate [fixed upstream]
+
+Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk>
+---
+ src/core/mount.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/mount.c b/src/core/mount.c
+index 40037e7..cddb5e2 100644
+--- a/src/core/mount.c
++++ b/src/core/mount.c
+@@ -295,7 +295,7 @@ static int mount_add_device_links(Mount *m) {
+         assert(m);
+-        p = get_mount_parameters(m);
++        p = get_mount_parameters_fragment(m);
+         if (!p)
+                 return 0;
+-- 
+1.8.3.1
+
index 6ed4fe09957791ee5107d06a119da4a7f07ddf92..bac2784370f0313437e90575c2b3e98a43ccc390 100644 (file)
@@ -44,6 +44,7 @@ SRC_URI = "git://anongit.freedesktop.org/systemd/systemd-stable;branch=v219-stab
            file://0014-Revert-rules-remove-firmware-loading-rules.patch \
            file://0015-Revert-udev-remove-userspace-firmware-loading-suppor.patch \
            file://tmpfiles-pam.patch \
+           file://0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch \
            file://touchscreen.rules \
            file://00-create-volatile.conf \
            file://init \