]> code.ossystems Code Review - openembedded-core.git/commitdiff
webkitgtk: do not inherit pythonnative
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>
Mon, 13 Jun 2016 13:11:25 +0000 (16:11 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 14 Jun 2016 11:56:32 +0000 (12:56 +0100)
Set the path to python 2.x explicitly instead; pythonnative
and python3native classes cannot be used in the same recipe.

Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/webkit/webkitgtk_2.12.3.bb

index 265fedb3494eb7020832e0c00df6bc737548a8d8..a77b086eb30b889eee4c32c352f4c1d167a04011 100644 (file)
@@ -21,10 +21,12 @@ SRC_URI = "\
 SRC_URI[md5sum] = "aebb4029c09dd81664aa830e4a584c85"
 SRC_URI[sha256sum] = "173cbb9a2eca23eee52e99965483ab25aa9c0569ef5b57041fc0c129cc26c307"
 
-# pythonnative must come after gobject-introspection, otherwise
-# webkit build configuration will not attempt to find Python 2.x after
-# finding (and rejecting) Python 3.x
-inherit cmake lib_package pkgconfig gobject-introspection perlnative pythonnative distro_features_check upstream-version-is-even
+inherit cmake lib_package pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even
+
+# We cannot inherit pythonnative because that would conflict with inheriting python3native
+# (which is done by gobject-introspection). But webkit only needs the path to native Python 2.x binary
+# so we simply set it explicitly here.
+EXTRANATIVEPATH += "python-native"
 
 # depends on libxt
 REQUIRED_DISTRO_FEATURES = "x11"